Bug 1516706 - [v2v] RHV ISO and export domain types and domains in maintenance/down state should not be listed in destination storage dropbox.
Summary: [v2v] RHV ISO and export domain types and domains in maintenance/down state s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: GA
: 5.10.0
Assignee: Shmuel Melamud
QA Contact: Nisim Simsolo
URL:
Whiteboard: rhv:v2v
: 1518395 (view as bug list)
Depends On:
Blocks: 1533550
TreeView+ depends on / blocked
 
Reported: 2017-11-23 10:03 UTC by Nisim Simsolo
Modified: 2018-06-21 20:44 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1533550 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:44:11 UTC
Category: ---
Cloudforms Team: RHEVM


Attachments (Terms of Use)
CFME transform dialog (75.29 KB, image/png)
2017-11-23 10:05 UTC, Nisim Simsolo
no flags Details
RHV storage tab (147.66 KB, image/png)
2017-11-23 10:06 UTC, Nisim Simsolo
no flags Details
Transform dialog screenshot 1 (79.87 KB, image/png)
2017-11-23 10:09 UTC, Nisim Simsolo
no flags Details


Links
System ID Priority Status Summary Last Updated
Github ManageIQ manageiq-content pull 229 None None None 2017-12-15 00:43:49 UTC

Description Nisim Simsolo 2017-11-23 10:03:48 UTC
Description of problem:
Currently it is possible to select ISO domain or export domain as a trasfoem storage destination in transform dailog.
It is also possible to select domains from different cluster than the selected cluster. 
And it is also possible to select domains which are in maintenance or down state.

The destination storage type should be data type, part of the selected cluster and in up state.

Screenshot of RHV storage tab and CFME transform dialog attached.

Version-Release number of selected component (if applicable):
cfme-5.9.0.10-1.el7cf.x86_64
rhevm-4.1.8-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Browse CFME UI -> Compute -> infrastructure -> providers -> select VMware environment-> VMs, tag VM to import -> lifecycle -> transform tagged VMs to RHV
2. Select provider and cluster
3. Drop storage dropbox

Actual results:
Dropbox is listing ISO and export domains, domains which are in maintenance or down state and domains from different cluster than the selected cluster.

Expected results:
The destination storage type should be data type, part of the selected cluster and in up state.

Additional info:
Screenshots attached

Comment 2 Nisim Simsolo 2017-11-23 10:05:46 UTC
Created attachment 1358110 [details]
CFME transform dialog

Comment 3 Nisim Simsolo 2017-11-23 10:06:09 UTC
Created attachment 1358111 [details]
RHV storage tab

Comment 4 Nisim Simsolo 2017-11-23 10:09:02 UTC
Created attachment 1358112 [details]
Transform dialog screenshot 1

Comment 5 Ilanit Stein 2017-12-10 12:52:25 UTC
Nisim,

Can you please check if this bug is still relevant, for CFME-5.9, after mass migration draw back?

Comment 6 Nisim Simsolo 2017-12-12 08:06:17 UTC
Still relevant, It looks like mass migration draw back is not applied yet.

Comment 7 Shmuel Melamud 2017-12-13 17:02:27 UTC
*** Bug 1518395 has been marked as a duplicate of this bug. ***

Comment 9 CFME Bot 2018-01-10 19:09:46 UTC
New commit detected on ManageIQ/manageiq-content/master:
https://github.com/ManageIQ/manageiq-content/commit/e03ea851e38cd3e50a5d0492bf121c010fedbcea

commit e03ea851e38cd3e50a5d0492bf121c010fedbcea
Author:     Shmuel Melamud <smelamud@redhat.com>
AuthorDate: Fri Dec 15 01:39:06 2017 +0200
Commit:     Shmuel Melamud <smelamud@redhat.com>
CommitDate: Wed Jan 10 19:44:28 2018 +0200

    Only data storage domains in VM transform dialog
    
    In VM transform dialog allow to select only data storage domains as the
    destination of VM transformation.
    
    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1516706

 .../Import.class/__methods__/list_storages.rb          |  2 +-
 .../Import.class/__methods__/list_storages_spec.rb     | 18 +++++++++++++-----
 2 files changed, 14 insertions(+), 6 deletions(-)


Note You need to log in before you can comment on or make changes to this bug.