Bug 151690 - RFE: Add USB install support
RFE: Add USB install support
Status: CLOSED DUPLICATE of bug 147256
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 13:50 EST by Bernd Bartmann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-01 15:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2005-03-21 13:50:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Please add support to anaconda to be able to install to USB storage devices.
Right now installing to USB devices is only possible in expert mode but the major missing feature is the creation of the final initrd with support for the needed USB and SCSI modules.

Here is how I managed to install FC4 to a CF Card connected to an USB CF card reader (The CF card was the only storage device in the system besides a USB DVD-ROM containing the FC4T1 install DVD):

1. enter "linux expert" at the syslinux prompt (expert is important because the USB storage devices are only available in disk-druid in this install mode)
2. you should now be able to partition the USB storage device as you like
3. install as usual but switch to Console #2 before the final reboot
4. chroot /mnt/sysimage
5. mkinitrd --preload=ehci-hcd --preload=usb-storage --preload=scsi_mod --preload=sd_mod /boot/usbinitrd.img 2.6.11-1.1177_FC4
6. edit /boot/grub/grub.conf to use the new initrd
7. Reboot

(8.) This seems to be a bug:
When system booted it found my CF card but could not mount / although the e2label was created during installation. So I changed root=LABEL=/ to root=/dev/sda1 in grub.conf and was finally able to successfully boot from my CF card.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try to install and boot from an USB storage device
2.
3.
  

Additional info:
Comment 1 Mike_Ciaraldi 2005-03-29 15:00:23 EST
I just downloaded the DVD image of FC4T1 and tried this. When I got to manual
partitioning with Disk Druid, it still only shows me the partitions on my
internal hard drive, but nothing on the USB drive at all. I tried changing to
Console #2 before running Disk Druid, then loading the USB modules (at least I
thought that is what I was doing), but DD still only sees the internal HD.
Comment 2 Bernd Bartmann 2005-03-29 15:10:56 EST
Are you sure that you selected "linux expert" at the syslinux boot prompt? This
a very important as otherwise the usb-storage modules will be ignored by disk-druid.
Comment 3 Mike_Ciaraldi 2005-04-01 17:26:43 EST
Here is what I did:

The USB disk was already partitioned using Knoppix.
I powered off the laptop (IBM Thinkpad T41), plugged in the USB drive, powered
up the laptop, and booted from the FC4T1 installation DVD.

When it stopped at the boot prompt, I typed "linux expert".
The boot continued. It started the GUI. I chose my language and keyboard
(English). There were a few more questions, including whether I had a driver
disk, I think; I said no. Then it asked if I wanted automatic or manual
partitioning. I chose manual. Disk Druid started up.

In the top part of the Disk Druid screen it has what appears to be a list of the
disks. The only one there was /dev/hda. On the bottom half of the screen was the
list of partitions on that disk, which were correct. I could not see any way of
switching to the USB disk.
----
I tried doing the same thing over again, but before I got to Disk Druid I used
Ctrl-Alt-F2 to go to another console. Then I used insmod to load all the modules
I thought I would need: usbcore, usb-storage, scsi-mod, sd-mod, uhci-hcd, and
ehci-hcd. Then I hit Ctrl-Alt-F7 and returned to the installation. When I got to
Disk Druid, it still only saw the IDE hard drive.

Bernd, is this different from the way you did it?
----
If I boot from a Knoppix CD, I can mount, read, and write the USB hard drive
with no trouble. So I know the Linux drivers work with my hardware.
Comment 4 Bernd Bartmann 2005-04-03 13:41:28 EDT
Interesting. This is exactly the same way as I did the installation. I tried it
on two different systems:
1. VIA MS10000 mainboard with on-board CF-Slot that is seen as an USB storage
device. The CF card was detected as /dev/sda when I booted with "linux expert".
Booting from the USB-CF-card works after the manual steps described above.
2. MSI KT6-Delta mainboard with external USB attached multi-card reader. The CF
card was detected as /dev/sda when I booted with "linux expert". Booting from
the USB-CF card did not work on this system due to a BIOS problem.

BTW: I had no other IDE devices in the system besides the DVD-ROM with the
install media.
Comment 5 Chris Lumens 2005-06-01 15:34:52 EDT
For various reasons we are not going to suppose installing to a USB device.  I'm
marking this one as a duplicate of a bug that has a pretty decent explanation of
why.  You can also try an advanced search looking for any closed anaconda bugs
with "usb" in the summary for further examples.

*** This bug has been marked as a duplicate of 147256 ***

Note You need to log in before you can comment on or make changes to this bug.