Bug 147256 - FC3 install to USB Disk Not possible ?
FC3 install to USB Disk Not possible ?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
: FutureFeature
: 150840 151690 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-05 05:49 EST by Dr J Austin
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-05 09:47:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dr J Austin 2005-02-05 05:49:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
With ext USB2 disks a reasonable price
why is it that the FC3 installer/DiskDruid seems to fail to detect
USB disks and hence you cannot install to a USB Disk.

I have two machines with USB2 support, one an AMD64 machine
The story is the same for both.

I have a 160GB SmartDisk that I plan to use for Photos, video,
backup etc but also for testing new releases of FC(4?) !!!!
However, the FC3 installer at the Disk Druid stage has no idea
that I have such a device !!!!

During FC3 Install "Cont/Alt/F2" lets me run fdisk on the device
(/dev/sda or /dev/sdb depending on which machine I'm working on) and
hence partition it,
mk... lets me make an ext3 file system on it, (/dev/sda1)
mkswap lets me make swap on /dev/sda2
mount /dev/sda1 /mnt/fred even lets me mount it.
All this "during" installation !!!!! So all the drivers, etc must
be installed and working!

However when I go to the Disk Druid stage I only see my
"main" disks (/dev/hda, /dev/sda for the SATA Athlon64 machine)?
No USB in sight.

The SmartDisk works perfectly as a normal data disk, either FAT32 or
ext3, giving data transfer rates between 20 and 30 MB/s.

Is there a way of forcing the installer to see the USB Disk ?
Can this be added to the wish list?




Version-Release number of selected component (if applicable):
anaconda-10.1.0.2-1,busybox-anaconda-1.00.rc1-5,...

How reproducible:
Always

Steps to Reproduce:
1.Try to install FC3 from CD/DVD to USB Disk
2.
3.
    

Additional info:
Comment 1 Jeremy Katz 2005-02-05 09:47:29 EST
USB disks aren't supported as installation targets due to the
unpredictability of being able to boot the machine in this sort of
setup after install.
Comment 2 Chris Lumens 2005-03-11 09:56:48 EST
*** Bug 150840 has been marked as a duplicate of this bug. ***
Comment 3 Mike_Ciaraldi 2005-03-26 07:35:09 EST
(In reply to comment #1)
> USB disks aren't supported as installation targets due to the
> unpredictability of being able to boot the machine in this sort of
> setup after install.

I am having this same problem on my IBM TRhinkpad T41.

Jeremy, are you saying that not supporting installation to USB disks is a
deliberate decision, made because of the unpredictability? I can understand
that. Would it be possible to make this an option, perhaps with a strong warning
that it might not work? I have heard of several people successfully booting
from USB hard drives, but it required manual adjustment of several configuration
files and rerunning mkinitrd, along with lots of trial-and-error. It would
certainly be more convenient if the standard installation procedure could just
set everything up on the USB drive as if it would work. 

The T41 supports booting from USB, and so far I have managed to get most of the
way to booting, but I am not quite there yet. 
Comment 4 Chris Lumens 2005-06-01 15:35:11 EDT
*** Bug 151690 has been marked as a duplicate of this bug. ***
Comment 5 Dr J Austin 2005-06-01 18:15:59 EDT
http://www.vigla.eclipse.co.uk/
may help

Note You need to log in before you can comment on or make changes to this bug.