Bug 151715 - umb-scheme seg faults on startup
umb-scheme seg faults on startup
Status: CLOSED DUPLICATE of bug 167017
Product: Fedora
Classification: Fedora
Component: umb-scheme (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 15:21 EST by Aaron VanDevender
Modified: 2013-07-02 19:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 02:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron VanDevender 2005-03-21 15:21:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
running umb-scheme with no arguments gives:

Fatal Error: Segmentation Violation.

and then starts with the REPL, however much of the language is missing since the seg violation happened while it was executing /usr/share/umb-scheme/prelude.scheme

The crash seems to happen with the (defmacro letrec ...) section, though I don't know what is causing it. The definition in prelude.scheme evaluates and operates normally when I run it through guile (after making appropriate substitutions for #_map1 etc.)

I went and tried this on an FC1 machine (umb-scheme-3.2-30) and got the same error, which means we've probably been carrying this bug for quite some time (which also probably says something about how often people use umb-scheme).

As far as I know the only reason we still include umb-scheme is because it's listed as a dependency for guile, but I don't know if that is still even necessary.

Version-Release number of selected component (if applicable):
umb-scheme-3.2-35

How reproducible:
Always

Steps to Reproduce:
  

Additional info:
Comment 1 Jindrich Novy 2005-03-22 05:33:05 EST
Yes, I tried to replace the umb-scheme package completely with slib because of 
legal issues (bug 125921) and also because of the heap corruption (122409) 
that causes the segfault. I'll try to test whether guile and gnucash works 
fine and remove the dependency on umb-scheme if everything works ok.

Jindrich
Comment 2 Jim J 2005-04-22 14:21:23 EDT
damn... 

I was hopeing that it would still be included.  I am just now getting into
programming scheme and was planning on using this.  

I guess I will have to find another approach.
Comment 3 Jindrich Novy 2005-09-09 02:28:55 EDT

*** This bug has been marked as a duplicate of 167017 ***

Note You need to log in before you can comment on or make changes to this bug.