Bug 167017 - umb-scheme seg faults on startup
umb-scheme seg faults on startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: umb-scheme (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
:
: 151715 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 12:16 EDT by Jón Fairbairn
Modified: 2013-07-02 19:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 02:26:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jón Fairbairn 2005-08-29 12:16:15 EDT
+++ This bug was initially created as a clone of Bug #151715 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302
Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
running umb-scheme with no arguments gives:

Fatal Error: Segmentation Violation.

and then starts with the REPL, however much of the language is missing since the
seg violation happened while it was executing /usr/share/umb-scheme/prelude.scheme

The crash seems to happen with the (defmacro letrec ...) section, though I don't
know what is causing it. The definition in prelude.scheme evaluates and operates
normally when I run it through guile (after making appropriate substitutions for
#_map1 etc.)

I went and tried this on an FC1 machine (umb-scheme-3.2-30) and got the same
error, which means we've probably been carrying this bug for quite some time
(which also probably says something about how often people use umb-scheme).

As far as I know the only reason we still include umb-scheme is because it's
listed as a dependency for guile, but I don't know if that is still even necessary.

Version-Release number of selected component (if applicable):
umb-scheme-3.2-35

How reproducible:
Always

Steps to Reproduce:
  

Additional info:

-- Additional comment from jnovy@redhat.com on 2005-03-22 05:33 EST --
Yes, I tried to replace the umb-scheme package completely with slib because of 
legal issues (bug 125921) and also because of the heap corruption (122409) 
that causes the segfault. I'll try to test whether guile and gnucash works 
fine and remove the dependency on umb-scheme if everything works ok.

Jindrich

-- Additional comment from plasticmonkeyz-fedora@yahoo.com on 2005-04-22 14:21
EST --
damn... 

I was hopeing that it would still be included.  I am just now getting into
programming scheme and was planning on using this.  

I guess I will have to find another approach.
Comment 1 Jón Fairbairn 2005-08-29 12:19:51 EDT
This bug is still present in FC4. In particular gnucash depends directly on
umb-scheme, so it's not exactly reassuring for users of gnucash.
Comment 2 Horst H. von Brand 2005-09-08 16:06:26 EDT
It is still present in rawhide, umb-scheme-3.2-39 (just updated)
Comment 3 Jindrich Novy 2005-09-09 02:26:23 EDT
Jón, Horst, I fixed slib so that it works now with gnucash. So after Bill adds a
dependency in gnucash to slib >= 3a1-5, we don't need umb-scheme any more.

IMHO this is good move as umb-scheme was shipped because of the slib inside and
I don't remember times when umb-scheme didn't segfault on startup. Its
development is stuck for a few years and it contains very bad code. If you want
to use Scheme, please look for alternatives such as DrScheme (Extras) or Guile
(Core).
Comment 4 Jindrich Novy 2005-09-09 02:29:02 EDT
*** Bug 151715 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2006-01-20 11:57:17 EST
From User-Agent: XML-RPC

umb-scheme-3.2-39.fc4.1 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Jón Fairbairn 2006-01-20 12:40:59 EST
Still present:

   pictogramme:~/
17:41:16$ rpm -q umb-scheme
umb-scheme-3.2-39.fc4
   pictogramme:~/
17:41:21$ umb-scheme
Welcome to UMB Scheme, version 3.2  Copyright (c) 1988,1996 William R Campbell.
UMB Scheme comes with ABSOLUTELY NO WARRANTY. This is free software and
you are free to redistribute it under certain conditions.
See the UMB Scheme Release Notes for details. Type Control-d to exit.

Loading /usr/share/umb-scheme/prelude.scheme...

Fatal Error: Segmentation Violation.

Reset (Use Control-d to quit UMB Scheme)
==>


But more to the point, 

   pictogramme:~/
17:43:58$ rpm -q --whatrequires umb-scheme
gnucash-1.8.12-0.fc4

Do we need another bug "gnucash depends on umb-scheme"?
Comment 7 Jindrich Novy 2006-01-20 12:56:23 EST
Note that the fixed version is umb-scheme-3.2-39.fc4.1.
Comment 8 Jón Fairbairn 2006-01-20 16:04:19 EST
Gah! I need to get a pair of spectacles.
umb-scheme-3.2-39.fc4 ... .1
does indeed work.

Note You need to log in before you can comment on or make changes to this bug.