Bug 151716 - Build-time dependencies not mentioned in BuildReq tags
Build-time dependencies not mentioned in BuildReq tags
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mgetty (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Maros Barabas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 15:21 EST by Binand Sethumadhavan
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:05:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHN screenshot (39.95 KB, image/png)
2005-03-21 21:51 EST, Binand Sethumadhavan
no flags Details

  None (edit)
Description Binand Sethumadhavan 2005-03-21 15:21:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
Mgetty SRPM has a number of buildrequires which are not mentioned in the specfile. The errors are apparent only very late in the build process.

imake: from XFree86-devel
gccmakedep: from XFree86-devel, but due to a bug in that package (#132121), Mgetty needs XFree86 as well.
tetex-dvips: For dvips, which is used to build mgetty.ps from mgetty.dvi in the doc subdirectory of the source tree. Without this, the %doc processing of the package fails.

Mgetty SRPM is needed to build mgetty+sendfax; as even in U4 I cannot see mgetty-sendfax package in my satellite (#112034).

Version-Release number of selected component (if applicable):
1.1.30-3

How reproducible:
Always

Steps to Reproduce:
1. download Mgetty SRPM from ftp.redhat.com
2. rpmbuild --rebuild mgetty-*.src.rpm
3. wait for the build to fail.
  

Actual Results:  Mgetty build fails

Expected Results:  brand new mgetty-*.i386.rpm's

Additional info:
Comment 1 Jason Vas Dias 2005-03-21 16:05:09 EST
I will add the buildrequires for tetex-dvips to the next release. 

But is the root problem that the mgetty-sendfax package is not in RHN ?

All mgetty subpackages are submitted to our RHEL-3 distribution and 
should be on the RHEL-3 CD ISOs. 

I've contacted the RHN team to ensure that they on on RHN also.

If you are having a problem accessing the mgetty RPMS, they can all be
downloaded from:
  http://people.redhat.com/~jvdias/mgetty/RHEL-3



 
Comment 2 Binand Sethumadhavan 2005-03-21 21:50:33 EST
Here is how RHN looks like right now (9:50 PM EST, 3/21/2005).
Comment 3 Binand Sethumadhavan 2005-03-21 21:51:18 EST
Created attachment 112200 [details]
RHN screenshot
Comment 4 Dennis Gregorovic 2005-03-24 00:20:48 EST
bug #112034 covers the issue of the mgetty sub-packages not being in RHEL 3 (I
just reopened it). Let's keep this ticket focused of the BuildRequires issues.  
Comment 5 RHEL Product and Program Management 2007-10-19 15:05:57 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.