Bug 15183 - autofs init script is confused by similar map names
Summary: autofs init script is confused by similar map names
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
: 16033 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-02 21:11 UTC by redhat
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-02 21:11:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description redhat 2000-08-02 21:11:13 UTC
Problem with /etc/rc.d/init.d/autofs:
Say, I have in my yellowpages two maps:
/users auto.users
/user auto.users

grep on line 107 causes /user to be skipped because /user matches the known
map /users. The correct solution would be to grep for whole words:
-a "`echo "$knownmaps" | grep \ $dir\  = ""
                              ^^     ^^ <- blank spaces

Comment 1 Nalin Dahyabhai 2000-08-02 22:33:20 UTC
This should be fixed in autofs-4.0.0pre7-22 and later.  Please reopen this bug
if you find that this is not the case.

Comment 2 Nalin Dahyabhai 2000-08-11 22:23:55 UTC
*** Bug 16033 has been marked as a duplicate of this bug. ***

Comment 3 Nalin Dahyabhai 2000-08-11 22:57:48 UTC
*** Bug 16033 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.