Bug 16033 - autofs init script excludes valid maps
autofs init script excludes valid maps
Status: CLOSED DUPLICATE of bug 15183
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-11 17:56 EDT by Steve Dum
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-11 18:39:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dum 2000-08-11 17:56:07 EDT
The autofs script has been 'enhanced' in 6.9 to remove
duplicate auto.master entries.  Nice idea, however, 
the implementation is faulty.  We have the following
entries in our yp auto.master (amoung others)

/users auto.users   -rw,hard,intr,noquota
/tools auto.project  -rw,hard,intr,noquota
/user auto.users   -rw,hard,intr,noquota
/home auto.users   -rw,hard,intr,noquota
/wv auto.wv    -rw,hard,intr,noquota
 
Since the code right now does a simple 
    "`echo "$knownmaps" | grep $dir`" = ""
rather than searching for duplicate entries, it searches 
for previous entries that contain the later string.

It was real surprising to see most of the mounts appear but
/user wouldn't mount.  (because /users was already a mount point.)
Comment 1 Nalin Dahyabhai 2000-08-11 18:23:58 EDT
This should already be fixed in the latest Raw Hide refresh from the build tree.

*** This bug has been marked as a duplicate of 15183 ***
Comment 2 Steve Dum 2000-08-11 18:39:46 EDT
Not True- Rawhide has 
hftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/autofs-4.0.0pre7-20.i386.rpm

which is the same version I have loaded.  It hasn't been fixed,
unless the package number didn't roll.
Comment 3 Nalin Dahyabhai 2000-08-11 18:57:51 EDT
As I marked in 15183, the bug was fixed in 4.0.0pre7-22.  Version 3.1.5-3 in
http://people.redhat.com/nalin/test/ also includes the fix.

*** This bug has been marked as a duplicate of 15183 ***

Note You need to log in before you can comment on or make changes to this bug.