Bug 1519096 - "Context Dir" and "Git Reference" are empty when clicking "advanced options" after clicking "Try Sample Repository"
Summary: "Context Dir" and "Git Reference" are empty when clicking "advanced options" ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.7.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1527638 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-30 06:33 UTC by Takayoshi Tanaka
Modified: 2018-04-05 09:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the sample Git reference and context dir for building images sample repositories was not used when clicking the "Try Sample Repository" link in the web console add to project dialog. The sample reference and context dir are now properly set in the build config that is created when the sample is used.
Clone Of:
Environment:
Last Closed: 2018-04-05 09:33:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
image1 (36.80 KB, image/png)
2017-11-30 06:34 UTC, Takayoshi Tanaka
no flags Details
image2 (54.77 KB, image/png)
2017-11-30 06:34 UTC, Takayoshi Tanaka
no flags Details
image3 (45.60 KB, image/png)
2017-11-30 06:34 UTC, Takayoshi Tanaka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:33:53 UTC

Description Takayoshi Tanaka 2017-11-30 06:33:05 UTC
Description of problem:
"Context Dir" and "Git Reference" are empty when clicking "advanced options" after clicking "Try Sample Repository"

Version-Release number of selected component (if applicable):
# oc version 
oc v3.7.9
kubernetes v1.7.6+a08f5eeb62
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ose37-master:8443
openshift v3.7.9
kubernetes v1.7.6+a08f5eeb62


How reproducible:
Always

Steps to Reproduce:
1. Click "Add to project" and "Browse Catalog"
2. Click ".NET Core Builder Images 2.0" (or another template which has a sample repository)
3. Click Next
4. [attached image1] Click "Try Sample Repository", application name and git URL are filled.
5. Click "advanced options"


Actual results:
[attached image2] 
"Git Reference" and "Context Dir" are empty. 

For .NET Core 2.0 s2i image, Git Reference should be "dotnetcore-2.0" and "Context Dir" should be "app". (see attached image3)

Once the user clicked "Try Sample Repository" at the dialog (image1), Web console no longer provides "Git Reference" and "Context Dir"

Expected results:
"Git Reference" and "Context Dir" are filled with the valid values.


Additional info:

Comment 1 Takayoshi Tanaka 2017-11-30 06:34:05 UTC
Created attachment 1360686 [details]
image1

Comment 2 Takayoshi Tanaka 2017-11-30 06:34:30 UTC
Created attachment 1360687 [details]
image2

Comment 3 Takayoshi Tanaka 2017-11-30 06:34:51 UTC
Created attachment 1360688 [details]
image3

Comment 5 Samuel Padgett 2017-11-30 20:38:23 UTC
enterprise-3.7 catalog PR: https://github.com/openshift/origin-web-catalog/pull/579

Comment 6 Samuel Padgett 2017-12-01 18:53:50 UTC
3.7.z console PR:

https://github.com/openshift/origin-web-console/pull/2551

Comment 8 Yadan Pei 2017-12-06 06:47:59 UTC
v3.7.13 doesn't include the changes yet, will check in next update

Comment 9 Yadan Pei 2017-12-08 02:49:54 UTC
Change to MODIFIED since fix not picked in OCP, and it couldn't be tested

Comment 13 Samuel Padgett 2017-12-20 15:41:01 UTC
*** Bug 1527638 has been marked as a duplicate of this bug. ***

Comment 17 Yadan Pei 2018-03-01 06:23:05 UTC
Issue reported in this bug has been fixed in v3.7.35(OCP v3.9.1 also has the fix)

Clicking "Try Sample Repository" in catalog wizard could fill "Context Dir" and "Git Reference" correctly if an imagestream has.

Move to VERIFIED

Comment 21 errata-xmlrpc 2018-04-05 09:33:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.