Bug 1527638 - "Try Sample Repository" does not set context path and git reference in catalog wizard
Summary: "Try Sample Repository" does not set context path and git reference in catalo...
Keywords:
Status: CLOSED DUPLICATE of bug 1519096
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Jessica Forrester
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-19 17:29 UTC by Severin Gehwolf
Modified: 2017-12-20 15:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 15:41:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of wizard with "Try Sample Repository" link which fails to populate extra fields. (215.39 KB, image/png)
2017-12-19 17:29 UTC, Severin Gehwolf
no flags Details

Description Severin Gehwolf 2017-12-19 17:29:16 UTC
Created attachment 1370126 [details]
Screenshot of wizard with "Try Sample Repository" link which fails to populate extra fields.

Description of problem:
There seems to be a regression in the formerly known "Try It" feature what now seems to be called "Try Sample Repository".

See this issue for details:
https://github.com/redhat-developer/s2i-dotnetcore-ex/issues/33

The imagestream in question has "sampleContextDir" and "sampleRef" annotations. Those were properly populated to the correct fields in older OpenShift versions.

In latest OpenShift Online those are not taken into account and, thus, deployment fails for the users. If they get correctly set via advanced settings things start to work.

These versions worked fine with the image stream[1]:

OpenShift Master:  v3.6.0+c4dd4cf
Kubernetes Master: v1.6.1+5115d708d7

These versions seem to be broken:

OpenShift Master:  v3.7.9 (online version 3.6.0.73.0)
Kubernetes Master: v1.7.6+a08f5eeb62

[1] https://github.com/redhat-developer/s2i-dotnetcore/blob/master/dotnet_imagestreams.json

Comment 1 Samuel Padgett 2017-12-20 15:41:01 UTC

*** This bug has been marked as a duplicate of bug 1519096 ***


Note You need to log in before you can comment on or make changes to this bug.