Bug 1520163 - libaesni-intel-samba4.so needs to be linked with -z noexecstack
Summary: libaesni-intel-samba4.so needs to be linked with -z noexecstack
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1520252 1520332 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-03 17:42 UTC by flashl
Modified: 2017-12-12 11:22 UTC (History)
12 users (show)

Fixed In Version: samba-4.7.3-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 11:22:28 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Samba Project 13174 None None None 2017-12-04 09:54:27 UTC

Description flashl 2017-12-03 17:42:25 UTC
Description of problem: 
Startup error message occurs after update to v 4.7.3

Version-Release number of selected component (if applicable):
V 4.7.3

How reproducible:
Error presents itself after reboot or manual startup using systemctl

Steps to Reproduce:
1. systemctl start nmb smb
2.
3.

Actual results:
journalctl -u nmb -b:
Dec 03 11:08:35 roxie.blkdiamonds.lan systemd[1]: Starting Samba NMB Daemon...
Dec 03 11:08:40 roxie.blkdiamonds.lan nmbd[1591]: /usr/sbin/nmbd: error while loading shared libraries: libaesni-intel-samba4.so: cannot enable executab
Dec 03 11:08:46 roxie.blkdiamonds.lan systemd[1]: nmb.service: Main process exited, code=exited, status=127/n/a
Dec 03 11:08:46 roxie.blkdiamonds.lan systemd[1]: Failed to start Samba NMB Daemon.
Dec 03 11:08:46 roxie.blkdiamonds.lan systemd[1]: nmb.service: Unit entered failed state.
Dec 03 11:08:46 roxie.blkdiamonds.lan systemd[1]: nmb.service: Failed with result 'exit-code'.

Expected results:
Normal clean startup for Samba services


Additional info:

Read Samba execstack discussion here: http://samba.2283325.n4.nabble.com/libaesni-intel-samba4-so-and-execstack-flag-td4725770.html

Installing execstack 0.5.0-13.fc27 and rebooting did not resolve complaint. Selinux is not complaining. Other than an attempt to downgrade have no idea how to troubleshoot.

Comment 1 Alexander Bokovoy 2017-12-04 08:20:51 UTC
Wrong component.

Comment 2 Alexander Bokovoy 2017-12-04 08:22:07 UTC
*** Bug 1520252 has been marked as a duplicate of this bug. ***

Comment 3 Fabiano Fidêncio 2017-12-04 10:57:39 UTC
*** Bug 1520332 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2017-12-04 13:34:41 UTC
samba-4.7.3-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-20cce77cfb

Comment 5 Fedora Update System 2017-12-08 23:27:03 UTC
samba-4.7.3-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-20cce77cfb

Comment 6 Fedora Update System 2017-12-12 11:22:28 UTC
samba-4.7.3-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.