Bug 1520252 - samba: /usr/sbin/smbd: error while loading shared libraries
Summary: samba: /usr/sbin/smbd: error while loading shared libraries
Status: CLOSED DUPLICATE of bug 1520163
Alias: None
Product: Fedora
Classification: Fedora
Component: samba   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-04 06:47 UTC by xiaoli feng
Modified: 2017-12-04 08:22 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-04 08:22:07 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description xiaoli feng 2017-12-04 06:47:11 UTC
Description of problem:

start smb service failed.

[root@kvm-02-guest02 ~]# systemctl status smb
● smb.service - Samba SMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2017-12-04 01:41:00 EST; 22s ago
  Process: 22053 ExecStart=/usr/sbin/smbd --foreground --no-process-group $SMBDOPTIONS (code=exited, status=127)
 Main PID: 22053 (code=exited, status=127)

Dec 04 01:41:00 kvm-02-guest02.rhts.eng.bos.redhat.com systemd[1]: Starting Samba SMB Daemon...
Dec 04 01:41:00 kvm-02-guest02.rhts.eng.bos.redhat.com smbd[22053]: /usr/sbin/smbd: error while loading shared libraries: libaesni-intel-samba4.so: cannot enable executable stack as shared object requires: Permi
Dec 04 01:41:00 kvm-02-guest02.rhts.eng.bos.redhat.com systemd[1]: smb.service: Main process exited, code=exited, status=127/n/a
Dec 04 01:41:00 kvm-02-guest02.rhts.eng.bos.redhat.com systemd[1]: smb.service: Failed with result 'exit-code'.
Dec 04 01:41:00 kvm-02-guest02.rhts.eng.bos.redhat.com systemd[1]: Failed to start Samba SMB Daemon.



Version-Release number of selected component (if applicable):
samba-4.7.3-2.fc28.x86_64
samba-common-libs-4.7.3-2.fc28.x86_64
4.15.0-0.rc1.git3.1.fc28.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install samba and start smb service
2.
3.

Actual results:
Start smb service failed.

Expected results:
Start smb service successfully.

Additional info:

Comment 1 Alexander Bokovoy 2017-12-04 08:22:07 UTC
There is no samba4 anymore, only samba package.

This bug is actually a duplicate of bug #1520163

*** This bug has been marked as a duplicate of bug 1520163 ***


Note You need to log in before you can comment on or make changes to this bug.