Bug 152183 - Xorg server doesn't support enhanced canadian keyboard layout.
Xorg server doesn't support enhanced canadian keyboard layout.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-25 14:06 EST by Ricky Ng-Adam
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 03:42:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 1350 None None None Never

  None (edit)
Description Ricky Ng-Adam 2005-03-25 14:06:01 EST
Description of problem:

Trying to "+Add..." French-Canadian keyboard, I get the following popup:

rror activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
60802000

If you report this situation as a bug, please include:
- The result of <b>xprop -root | grep XKB</b>
- The result of <b>gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd</b>


Version-Release number of selected component (if applicable):

control-center-2.9.91-1

How reproducible:

always

Steps to Reproduce:
1. Desktop > Preferences > Keyboard
2. Layouts > +Add..
3. Select French Canadian
  
Actual results:

-Error activating XKB configuration popup
-Keyboard not available with the keyboard indicator
-Popup appears at every boot

Expected results:

-Working french-canadian keyboard

Additional info:

= xprop -root | grep XKB =

_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

= gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd =

 layouts = [us,ca_enhanced]
 model = pc105
 overrideSettings = false
 options = [grp grp:alts_toggle]
Comment 1 Som-Som 2005-04-07 04:45:54 EDT
This report is similar to bug 122664 and bug 139480.
Comment 2 Mike A. Harris 2005-04-07 22:09:21 EDT
If you use the ca_enhanced keyboard layout, you can not combine it with
any other layout due to limitations in Xkb currently.  The Xkb maintainers
have been exploring solutions to this problem for about 2 years now, but
no solution has come forth.

The issue is tracked in several freedesktop.org bug reports already,
but I do not have the bug ID's handy.  The problem is well known, but no
simple solution is available.  If anyone is interested in the detailed
explanation of the issues involved, I would suggest searching freedesktop
bugzilla for both open and closed bug reports with "ca_enhanced" in a
comment.

Hope this helps.

This bug seems to have similar symptoms to the bugs referenced in
comment #1, but is not an exact duplicate.
Comment 3 Leslie Satenstein 2006-01-19 08:37:37 EST
ca_enhanced.  Works just fine in Core4. It is not defined in Core 5 test2.

ca fr-legacy does not work properly in Core 5 Test 2.

Canada uses ca-enhanced in Federal Government, and in all of the French Speaking
areas of country (4 million people), and for international communications.  

Since the present Core4 version works, why not migrate it's logic to core5?  

ca fr-legacy does work for most keys, but not for ç bôite, ètè and many other
accented vowels. Also AltChar key and E yields Euro symbol. 

ca fr-legacy

Physical keyboards from IBM, Microsoft, Benq, all work properly
Comment 4 Leslie Satenstein 2006-01-24 18:40:06 EST
I had the Gnome  ca fr Multilingual working, after a friend ported the
appropriate files from Core4.  However, the port that he did only brought over
the definitions for Gnome, and not for KDE. 

With that definition, the alt-char key does not allow for the entering of many
special characters, such as the at symbol, or the open and close (French)
quotation marks «Z»

Would like to see this problem tackled soon. It prevents me from further testing.

Comment 5 Ray Strode [halfline] 2006-01-25 11:25:54 EST
I think the problem may go away when Xorg stops shipping its own xkb data and
switches to xkeyboard-config.  I'm going to reassign to the X team, so they can
close this when that happens.

I'm not positive that the problem will go away if we switch to xkeyboard-config
's xkb data but someone on the X.org team may know.
Comment 6 Rahul Sundaram 2006-02-20 06:21:27 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 7 Leslie Satenstein 2006-02-21 12:02:45 EST
Regretfully, the bug is still there, and here is additional information.

a) the superterminal in kde has a keyboard layout that appears to be USA
standard, even though the CA(FR) keyboard was requested.

Using the "normal terminal" in kde appears to map the version of canadian french
that is the incorrect one.

The linux command  setxkbmap "ca(fr)" via the terminal or shell loads the
correct keyboard definition, but not for the kde superterminal 

The top row of the correct keyboard mapping, unshifted, from left to right,
is  # normal 1 normal 2 normal  ... 9 normal 0 normal - normal and = 
with upper case shift it is
| pipe    ! exclamation mark " double quote / forward slash ... _ underbar + plus

The alt key characters are, in part:
\ bacslash, ± plus-minus, @ at symbol, £ pound ... ¼ (zero key), ½ hyphen key
and ¾  The rightmost key before the backspace.

And  the alt-char and e key for the Euro symbol.

Lets get it fixed, including the shells (ctl-alt-F1, F2..)  
Comment 8 Leslie Satenstein 2006-02-21 12:11:12 EST
What I was showing by the key mappings is what it should be, and not what it
incorrectly is.  The programmer who is assigned can check the Core 4 settings
which I listed to get the correct mapping.

I would do the mappying, were I to have the information.

Comment 9 Mike A. Harris 2006-03-09 03:42:13 EST
(In reply to comment #5)
> I think the problem may go away when Xorg stops shipping its own xkb data and
> switches to xkeyboard-config.  I'm going to reassign to the X team, so they can
> close this when that happens.
> 
> I'm not positive that the problem will go away if we switch to xkeyboard-config
> 's xkb data but someone on the X.org team may know.

We've switched to xkeyboard-config 0.8 in FC5 now, so I'm closing this report
as fixed in rawhide, however if someone still experiences the problem, they
should report it to X.Org bugzilla at http://bugs.freedesktop.org so the
xkeyboard-config maintainer is aware of the problem and can address it in
the next release.  In this case, please paste the X.Org bug URL here and
Red Hat will track the issue in X.Org bugzilla and review any fixes that
become available for consideration in future updates.
Comment 10 Leslie Satenstein 2006-03-09 12:53:23 EST
Every fix that was provided but one works for my Core5 test3 environment. 
I will enumerate them
Gnome GUI;-- works 100%
Gnome terminal works 100%
KDE GUI  -- works 100%
evolution, etc 100%
kde terminal 100%
tty access(CTL-ALTF1--Fx) works 100% 

but

KDE Superterminal  - 30% (ie 70% less 100% is negative 30%  keyboard is some
abomination, not US or Canadian.


Note You need to log in before you can comment on or make changes to this bug.