Bug 152210 - system-config-keyboard has errors in %post and %postun scripts
system-config-keyboard has errors in %post and %postun scripts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
: 152229 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-26 08:46 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.5-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 09:56:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-03-26 08:46:42 EST
Description of problem:
system-config-keyboard has errors in %post and %postun scripts.

Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.5-2

How reproducible:
Everytime, install or uninstall the package.

Actual results:
The current %post and %postun sections should be changed to:

touch --no-create %{_datadir}/icons/hicolor
if [ -x /usr/bin/gtk-update-icon-cache ]; then
  gtk-update-icon-cache %{_datadir}/icons/hicolor >> /dev/null
fi

The changes are:
- "[ -x" instead of "[-x]", which fails
- piping the output of gtk-update-icon-cache to /dev/null

Expected results:
This change or better...
Comment 1 Warren Togami 2005-03-27 16:31:27 EST
*** Bug 152229 has been marked as a duplicate of this bug. ***
Comment 2 Robert Scheck 2005-03-29 09:56:45 EST
Fixed in -3, closing now.
Comment 3 Clyde E. Kunkel 2005-03-29 11:18:52 EST
As of 3-29-05 rawhide, the error is now:
  Cleanup   : system-config-keyboard       ####################### [59/87]
/var/tmp/rpm-tmp.49858: line 2: [-x: command not found
Comment 4 Robert Scheck 2005-03-29 11:21:44 EST
Use a synced mirror which has Rawhide of today, then everything will work fine.

Note You need to log in before you can comment on or make changes to this bug.