Bug 1522705 - Unable to change quota from horizon dashboard
Summary: Unable to change quota from horizon dashboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Radomir Dopieralski
QA Contact: Beth White
URL:
Whiteboard:
: 1525382 (view as bug list)
Depends On:
Blocks: 1702261
TreeView+ depends on / blocked
 
Reported: 2017-12-06 09:52 UTC by Rahul Chincholkar
Modified: 2019-04-23 10:51 UTC (History)
8 users (show)

Fixed In Version: python-django-horizon-13.0.1-0.20180323102048.4dd4ef0.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1702261 (view as bug list)
Environment:
Last Closed: 2019-04-23 10:49:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1713724 None None None 2017-12-19 01:58:08 UTC
OpenStack gerrit 510188 'None' 'MERGED' 'Correct quota usage check for instances' 2019-12-06 17:50:28 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:41:00 UTC

Description Rahul Chincholkar 2017-12-06 09:52:42 UTC
Description of problem:
I have two projects admin and Project1

On admin project, I have 6 instances running with m1.tiny flavor (64MB RAM / 1GB Disk / 1 vCPUs)
Admin project Current RAM usage - 384MB

Then, I go to Identity -> project2 -> Edit Project -> Quota
and tried to modify RAM(MB) to 300
got following error:

~~~
Quota value(s) cannot be less than the current usage value(s): 384 RAM (MB) used.
~~~


Note : It is working as expected when I switch project by clicking Project dropdown menu on top right hand side on the dashboard. 
But as I am using admin user, I should be able to edit other project quotas without switching the project. I was also able to modify quotas from CLI.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Comment 2 Radomir Dopieralski 2017-12-13 09:43:28 UTC
*** Bug 1525382 has been marked as a duplicate of this bug. ***

Comment 3 Radomir Dopieralski 2017-12-19 01:59:32 UTC
This is fixed in Queens with https://review.openstack.org/510188

Comment 9 errata-xmlrpc 2018-06-27 13:40:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.