Bug 152285 - Assertion failure with --import and HTTP redirect
Assertion failure with --import and HTTP redirect
Status: CLOSED DUPLICATE of bug 189107
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 166338 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-27 07:37 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-02 08:07:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-03-27 07:37:39 EST
rpm-4.4.1-8:

# rpm --import http://www.pixelbeat.org/pixelbeat.asc
error: http://www.pixelbeat.org/pixelbeat.asc: import read failed(-1).
rpmk: url.c:103: XurlFree: Assertion `u && u->magic == 0xd00b1ed0' failed.
Aborted (core dumped)

gdb backtrace:
#0  0x002557e2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00299a7c in raise () from /lib/tls/libc.so.6
#2  0x0029b1c8 in abort () from /lib/tls/libc.so.6
#3  0x00292c9e in __assert_fail () from /lib/tls/libc.so.6
#4  0x0074c1ed in XurlFree (u=0x8df4518, msg=0x0, file=0x77fc3e "url.c",
    line=175) at url.c:103
#5  0x0074c6f5 in urlFreeCache () at url.c:175
#6  0x080497cb in main (argc=3, argv=0xbfa6fca4) at ./rpmqv.c:882
#7  0x00286db6 in __libc_start_main () from /lib/tls/libc.so.6
#8  0x080493b1 in _start ()

The URL http://www.pixelbeat.org/pixelbeat.asc is a valid URL, but it results in
a "302 Moved Temporarily" redirect, which rpm doesn't seem to like.

The same operation on FC3 (rpm-4.3.2-21) doesn't work either, but results in
less noisy error:
error: http://www.pixelbeat.org/pixelbeat.asc: import read failed.
Comment 1 Paul Nasrat 2005-11-28 15:20:13 EST
*** Bug 166338 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Johnson 2006-07-02 08:07:21 EDT

*** This bug has been marked as a duplicate of 189107 ***

Note You need to log in before you can comment on or make changes to this bug.