Bug 166338 - HTTP install can't handle redirects
HTTP install can't handle redirects
Status: CLOSED DUPLICATE of bug 152285
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-19 09:02 EDT by Andrew Benham
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 15:19:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Benham 2005-08-19 09:02:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Want to be able to download the current version of our own corporate packages
in automated scripts.  Don't want to have to search for explicit version/release
numbers.
A web server has all the details:

$ telnet cvs.thus.net 80
Trying 194.217.90.208...
Connected to cvs.thus.net (194.217.90.208).
Escape character is '^]'.
GET /cgi-bin/pkgget.cgi/THUSdisktype/RedHat-EL.4-i386 HTTP/1.0
Host: cvs.thus.net

HTTP/1.1 302 Moved
Date: Fri, 19 Aug 2005 12:56:41 GMT
Server: Apache/1.3.19 (Unix)
location: http://cvs.thus.net/pub/packages/main/RedHat-EL.4-i386/THUSdisktype-8-1.i386.rpm
Connection: close
Content-Type: text/plain

Connection closed by foreign host.

The redirected location exists, is correct, and is downloadable.


However RPM can't install using this URL:

$ rpm -ivh http://cvs.thus.net/cgi-bin/pkgget.cgi/THUSdisktype/RedHat-EL.4-i386
Retrieving http://cvs.thus.net/cgi-bin/pkgget.cgi/THUSdisktype/RedHat-EL.4-i386
error: skipping http://cvs.thus.net/cgi-bin/pkgget.cgi/THUSdisktype/RedHat-EL.4-i386 - transfer failed - Unknown or unexpected error


Fedora Core 4 fails in a different manner:

$ rpm -ivh http://cvs.thus.net/cgi-bin/pkgget.cgi/THUSdisktype/RedHat-FC.4-i386
Retrieving http://cvs.thus.net/cgi-bin/pkgget.cgi/THUSdisktype/RedHat-FC.4-i386
/var/tmp/rpm-xfer.tpt4qG: not an rpm package (or package manifest):


Version-Release number of selected component (if applicable):
4.3.3

How reproducible:
Always

Steps to Reproduce:
1. Create script to redirect to a valid URL
2. Use 'rpm -i' with the script's URL
3.
  

Actual Results:  "Unknown or unexpected error"

Expected Results:  Package installed.

Additional info:
Comment 1 Paul Nasrat 2005-08-19 10:08:27 EDT
Note, as documented on https://bugzilla.redhat.com/ all RHEL support requests
should be directed through support to obtain correct prioritisation, etc.

https://www.redhat.com/apps/support/

Out of curiosity why aren't you using up2date with a repository/channel setup up
for your corporate packages?
Comment 2 Andrew Benham 2005-08-19 10:15:12 EDT
Because we want exactly one solution to cover all our supported platforms -
FreeBSD, HP-UX,  RedHat Enterprise Linux, Fedora Core Linux, and Solaris.
Comment 3 Paul Nasrat 2005-11-28 15:19:51 EST

*** This bug has been marked as a duplicate of 152285 ***

Note You need to log in before you can comment on or make changes to this bug.