Bug 15242 - X Freeze
X Freeze
Status: CLOSED DUPLICATE of bug 12611
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 11:29 EDT by Wil Harris
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 10:43:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wil Harris 2000-08-03 11:29:53 EDT
I was playing around with X, and my favorite window manager (my own little
hack of fvwm2) and my machine just froze solid. Now when I am working on
this I always start another X session on :1 with a hacked startx file, and
run my window manager on that (E runs on :0). Everything was going fine,
until I closed out the one on :1, and went back to the one on :0 which had
turned my rxvt sessions into the background from my :1 session, so I went
to switch back to the console and make sure everything had exited cleanly
when the machine hard locked. I had to use cntrl-alt-syrq to get the
machine to reboot. Neither of these sessions were running as the same
users (I created a special user for working on my window manager
files...just in case). Once the machine came back up I decided to see if
it was just a fluke, or something I could repeat, by going through my
normal process (login as user1, startx, get everything setup,
dialup,switch to console, login as user2, startx. work on the config,
exit, go back to first session) and the system was hard locked. I tend to
switch between these 2 desktops  doing different tasks. The system
hardware list is below.

Dual PIII 650Mhz CPU
128 Megs of Ram
VooDoo3 3500 PCI
AHA-2940U2/W
Ensoniq ES1370 [AudioPCI]
2 20 Gig IDE drives
2 9gig cheetah drives
1 CD burner
1 48x CD rom
PS/2 logitech trackball
eepro100 ethernet
17" Sony trinitron flat screen

On another note, subsequent testing does NOT result in a hard lock of the
system, but does result in the system being unresponsive to keyboard
commands, but the mouse moves.
Comment 1 Glen Foster 2000-08-04 11:25:12 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 2 David Balažic 2000-08-10 07:24:21 EDT
will suggested that I add my experience :

I had an X related crash on my pinstripe GNOME system.

I logged on as root on X ( VT7 , the gdm thing )
log on as non-root on VT1 ( text console )
run on VT1 : startx -- :1 ( brings up a GNOME desktop on VT8 )
Did some "Work" in VT7 ( root ) and logged out.

Switched to VT8.
The mouse pointer moved erratically for a second and there was some
slow redraw problem IIRC. There was only one gnome-terminal window
and the GNOME desktop, nothing else. Then it froze. Nothing works,
only the mouse pointer ( like with Win 3.x :-)
No console switching, not X zapping ( ctrl-alt-backspace ),
not ctrl-alt-del. I had SysRq disabled , so I didn't try it.

I don't know if this is reproducible.

It was XF86 4.0.1 with the "nv" driver ( rivaTNT card ).

Comment 3 Bill Nottingham 2000-08-14 15:28:08 EDT
Many of the XFree4 drivers seem to have issues with running
multiple servers simultaneously, as far as I can tell. :(
Comment 4 Mike A. Harris 2001-03-08 10:43:11 EST
Try the latest XFree86 from:

ftp://people.redhat.com/mharris/xfree86

and update the bug report to let me know if it works for you.
Comment 5 Mike A. Harris 2001-03-20 02:03:39 EST

*** This bug has been marked as a duplicate of 12611 ***

Note You need to log in before you can comment on or make changes to this bug.