Bug 152444 - flac-1.1.2-1 depends on an old version of itself, can't be installed
flac-1.1.2-1 depends on an old version of itself, can't be installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: flac (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
: 152453 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 11:42 EST by John Thacker
Modified: 2013-03-13 00:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 12:51:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Thacker 2005-03-29 11:42:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2 Fedora/1.0.2-2

Description of problem:
flac-1.1.2-1, just added to rawhide, picked up a dependency against its own older version when being built in rawhide.  (An annoying problem, but one I've seen before.)  As a result, the package depends on libFLAC.so.4 and can't be installed, since it doesn't provide libFLAC.so.4 but rather libFLAC.so.7  It needs to be rebuilt again so that it picks up its own proper dependencies and can be installed.

Version-Release number of selected component (if applicable):
flac-1.1.2-1

How reproducible:
Always

Steps to Reproduce:
1.  rpm -Uvh flac-1.1.2-1.i386.rpm, or
2.  yum install flac
  

Actual Results:  It won't install, with an error like:
Error: Missing Dependency: libFLAC.so.4 is needed by package flac


Expected Results:  It should install.

Additional info:
Comment 1 John (J5) Palmieri 2005-03-29 12:51:53 EST
fixed.  thanks.
Comment 2 John (J5) Palmieri 2005-03-29 13:43:36 EST
*** Bug 152453 has been marked as a duplicate of this bug. ***
Comment 3 David Juran 2005-05-29 13:52:58 EDT
I think this bug has resurfaced again. I see it in flac 1.1.2-25
Comment 4 David Juran 2005-05-29 14:39:39 EDT
What I meant in comment 3 is that when I rebuild flac-1.1.2-25 on my machine, I
get this dependency.
This bug really looks to me a lot like bug 132435. Could someone please reopen
this issue and reassign it to libtool? I'm using libtool-1.5.18-2

Below is the snippet from my build log where things go wrong.

 /bin/sh ../../libtool --mode=install /usr/bin/install -c  'libOggFLAC.la'
'/var/tmp/flac-root/usr/lib/libOggFLAC.la'
libtool: install: warning: relinking `libOggFLAC.la'
(cd /home/david/fedora/devel/flac/flac-1.1.2/src/libOggFLAC; /bin/sh
../../libtool  --tag=CC --mode=relink gcc -I../.. -I./include -I../../include
-DNDEBUG -Wall -W -Winline -DFLaC__INLINE=__inline__ -O2 -g -pipe -m32
-march=i386 -mtune=pentium4 -o libOggFLAC.la -rpath /usr/lib -version-info 3:0:0
file_decoder.lo file_encoder.lo ogg_decoder_aspect.lo ogg_encoder_aspect.lo
ogg_helper.lo ogg_mapping.lo seekable_stream_decoder.lo
seekable_stream_encoder.lo stream_decoder.lo stream_encoder.lo -L/usr/lib -logg
../libFLAC/libFLAC.la -inst-prefix-dir /var/tmp/flac-root)
gcc -shared  .libs/file_decoder.o .libs/file_encoder.o
.libs/ogg_decoder_aspect.o .libs/ogg_encoder_aspect.o .libs/ogg_helper.o
.libs/ogg_mapping.o .libs/seekable_stream_decoder.o
.libs/seekable_stream_encoder.o .libs/stream_decoder.o .libs/stream_encoder.o 
-L/usr/lib -logg -L/var/tmp/flac-root/usr/lib -lFLAC  -m32 -march=i386
-mtune=pentium4 -Wl,-soname -Wl,libOggFLAC.so.3 -o .libs/libOggFLAC.so.3.0.0
/usr/bin/install -c .libs/libOggFLAC.so.3.0.0T
/var/tmp/flac-root/usr/lib/libOggFLAC.so.3.0.0

Note You need to log in before you can comment on or make changes to this bug.