Bug 152570 - Unable to use standard hotkeys with Russian xkb layout
Unable to use standard hotkeys with Russian xkb layout
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 147092 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 09:15 EST by Leonid Kanter
Modified: 2013-12-24 04:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 09:14:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 103331 None None None Never

  None (edit)
Description Leonid Kanter 2005-03-30 09:15:37 EST
Description of problem:

If Russian xkb layout is active, it's impossible to use keyboard shortcuts like
ctrl-c (copy), ctrl-v (paste) etc. It makes this build of openoffice absolutely
unusable for somebody who was using other office (microsoft) or other build of
openoffice.org for a long time.

Version-Release number of selected component (if applicable):

1.9.87-2

How reproducible:

always

Steps to Reproduce:
1. Start gnome keyboard properties and select Russian layout
2. Start openoffice writer and verify that keyboard produces kyrillic characters.
3. Try to use ctrl-c and ctrl-v for copy and paste text
  
Actual results:

Nothing will happen

Expected results:

Ctrl-c and ctrl-v should work for copy and paste

Additional info: 

This bug was not reproduced with openoffice.org build from
http://www.openoffice.org.
Comment 1 Caolan McNamara 2005-04-08 10:37:35 EDT
*** Bug 147092 has been marked as a duplicate of this bug. ***
Comment 2 Leonid Kanter 2005-05-04 13:14:27 EDT
Looks like it's not openoffice.org bug, because it works great in KDE. It's
gnome bug, and it's hanging on gnome bugzilla for a long time, see
http://bugzilla.gnome.org/show_bug.cgi?id=103331

no idea what component shoud be chosen :(
Comment 3 Nrbrtx 2013-12-24 04:22:13 EST
This bug exists in Ubuntu too https://bugs.launchpad.net/unity/+bug/1226962 (200 users affected).
Comment 4 Nrbrtx 2013-12-24 04:27:17 EST
GNOMErs think that corresponding bug is https://bugzilla.gnome.org/show_bug.cgi?id=678001 .

Note You need to log in before you can comment on or make changes to this bug.