Bug 1526109 - [Lenovo RFE] Add Lenovo Ironic XClarity Driver [NEEDINFO]
Summary: [Lenovo RFE] Add Lenovo Ironic XClarity Driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 14.0 (Rocky)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: Upstream M1
: 15.0 (Stein)
Assignee: Dmitry Tantsur
QA Contact: mlammon
URL: http://specs.openstack.org/openstack/...
Whiteboard:
Depends On:
Blocks: 1476902 1656890
TreeView+ depends on / blocked
 
Reported: 2017-12-14 18:54 UTC by rchugh1
Modified: 2019-09-26 10:44 UTC (History)
16 users (show)

Fixed In Version: openstack-ironic-12.1.2-0.20190615000404.c3cbdb5.el8ost
Doc Type: Technology Preview
Doc Text:
A new Red Hat OpenStack Platform Bare Metal service (ironic) driver for XClarity managed Lenovo devices is available. The xclarity driver provides more reliable operation on Lenovo devices managed with XClarity, and opportunities for additional vendor-specific features in the future.
Clone Of:
: 1656890 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:15:27 UTC
Target Upstream Version:
mknutson: needinfo? (rchugh1)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1702508 0 None None None 2017-12-14 18:54:35 UTC
OpenStack gerrit 519427 0 None MERGED Add XClarity Driver 2020-10-23 18:36:00 UTC
OpenStack gerrit 541565 0 None MERGED Add XClarity in the list of supported hw types 2020-10-23 18:36:00 UTC
OpenStack gerrit 541570 0 None MERGED Add XClarity in the list of supported hw types 2020-10-23 18:36:00 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:16:08 UTC

Description rchugh1 2017-12-14 18:54:36 UTC
Description of problem:

There is no support for Lenovo XClarity driver in RHOSP as of today and there is a review upstream https://review.openstack.org/#/c/519427 that aims to add support for it. Spec for the driver is already merged upstream at https://review.openstack.org/#/c/476922/.

Version-Release number of selected component (if applicable):
OpenStack Ironic Queens


How reproducible:
Load the Ironic service in RH OpenStack and there is no support for Lenovo XClarity driver

Steps to Reproduce:
1.
2.
3.

Actual results:
There is no XClarity Ironic driver in RHOSP yet

Expected results:
There is XClarity Ironic driver support for RHOSP 13 as the driver is intended to merge upstream in Queens.


Additional info:

Comment 2 Dmitry Tantsur 2017-12-20 13:03:26 UTC
Hi!

Thanks for your request. Setting OtherQA, as we'll need help with testing the new driver.

Is Lenovo planning on implementing TripleO integration for the driver as well?

Comment 3 rchugh1 2017-12-20 14:41:27 UTC
Hi!

We're testing this on RHOSP Director and have this tested end to end on RHOSP 10. We need more guidance as to how to implement TripleO integration for the driver?

Thanks
Rushil

Comment 4 Dmitry Tantsur 2017-12-20 15:20:44 UTC
I don't think we have a guide on how to support new drivers in TripleO, unfortunately. I know that you need to update https://github.com/openstack/tripleo-common/blob/master/tripleo_common/utils/nodes.py to enable enrolling of the nodes with the driver. Then you may have to update https://github.com/openstack/python-tripleoclient/blob/master/tripleoclient/v1/undercloud_config.py#L388 to simplify enabling your driver.

Comment 5 Dave Cain 2018-01-22 16:43:57 UTC
Rushil, did Dmitry's comment make sense?

Comment 6 rchugh1 2018-01-22 19:25:59 UTC
Dave,
Yes, it did. I was waiting it to land upstream. I am working on a patch for RHOSP 14 now and then I will backport it to RHOSP13.

Thanks
Rushil

Comment 7 rchugh1 2018-02-06 18:40:44 UTC
The code has landed upstream btw and we are working on a tripleO patch for the same.
(In reply to rchugh1 from comment #6)
> Dave,
> Yes, it did. I was waiting it to land upstream. I am working on a patch for
> RHOSP 14 now and then I will backport it to RHOSP13.
> 
> Thanks
> Rushil

Comment 8 rchugh1 2018-02-07 06:53:52 UTC
FYI: Just added patches https://review.openstack.org/541565 and  https://review.openstack.org/541570 for the same.

Comment 9 Ramon Acedo 2018-04-13 09:51:23 UTC
Approving for OSP 14. Please post the test results with OSP 14 here. When planning to backport to OSP 13, please create a separate RFE to track the backport and the results of the test. Thanks.

Comment 13 Monte Knutson 2018-04-17 21:57:40 UTC
Per request from Lenovo - Removing Private and Lenovo Confidential groups. This bug is now open to everyone. Please be careful with any confidential information and do not include it here.  Thanks,  Monte

Comment 15 Dmitry Tantsur 2018-07-25 17:01:50 UTC
Given that the driver is still unsupported because of lack of the 3rd party CI, and that upstream is planning on deprecating it for Rocky [1], moving the RFE to 15. Please make sure the CI is in place early in Stein, otherwise the driver will be removed.

[1] https://review.openstack.org/#/c/585818/

Comment 17 Ramon Acedo 2018-07-26 08:50:16 UTC
In order for this driver to be present in OSP it needs to be present upstream. I suggest that Lenovo ensures all the requirements are met to be present upstream so that it is included in OSP.

We can track it here for Stein and eventually have it in OSP 15.

Comment 18 Monte Knutson 2018-07-26 11:55:14 UTC
Miro - This will not make OSP 14 because all work was not completed and accepted upstream in time. Please let the team know and have them work with the community to finish the needed work.  Monte

Comment 20 jiapei 2018-09-20 15:25:53 UTC
Hi Monte,

I'm JiaPei from Lenovo, currently I'm responsible for Ironic XClarity Drivers. We're now setting up CI with the community(including Julia and the openstack-infra team).

Jia Pei

Comment 26 jiapei 2018-11-12 01:56:25 UTC
Hi,

Lenovo XClarity CI is ready, the log server is at http://lxca-logs.electronicjungle.net/. However, we need more test on the driver and are doing Tempest test currently.

Comment 27 jiapei 2018-12-01 14:00:02 UTC
I'd like to have a summary of the current CI status.

Archievements are as below:
1. Our CI infrastructure is ready: We have Zuul V3, Nodepool V3 and public log server set up correctly, which has been working and posting feedback to Ironic for almost 1 month.
2. We have tested that the individual function(Power on/off, Get/Set boot order) of XClarity driver works.

Issue happens when Julia asked us to run Tempest:
1. XClarity driver failed to deploy a baremetal driver.

To narrow down the issue we began to use IPMI driver to deploy our baremetal node.

However we failed to deploy with IPMI driver too. It means that we need to determine the correct network/devstack/iSCSI configuration first. We need to get support from community and Redhat on these configurations.

Comment 29 jiapei 2019-01-17 08:47:28 UTC
Hi,

We have made some progress on XClarity driver deployment. Manually deployment using 'openstack ironic deploy server-*' is successful and we have started to enable deployment test in the 3rd party CI. Can we add this driver to OSP now?

Comment 30 Dmitry Tantsur 2019-01-17 09:39:02 UTC
Hi,

This request is marked as POST and targets OSP 15, so you don't have to do anything else to get it there. Note that it's marked OtherQA, so you'll have to provide QA coverage when you get a build of OSP 15 (probably later in the cycle, I'm not sure how it works).

Comment 33 Monte Knutson 2019-09-06 15:00:50 UTC
Lenovo, 

Please test and provide feedback of results here.

Monte

Comment 34 Jay S Bryant 2019-09-06 15:08:56 UTC
Monte,

Will do.  We are planning to do some RHOSP15 tests with LOC and can make sure to verify this at the same time.

Thanks!
Jay

Comment 36 errata-xmlrpc 2019-09-21 11:15:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.