Bug 1526215 - cannot continue to process template once back to initial page from 'Import YAML/JSON'
Summary: cannot continue to process template once back to initial page from 'Import Y...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.7.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1530507
TreeView+ depends on / blocked
 
Reported: 2017-12-15 02:23 UTC by shahan
Modified: 2018-01-23 17:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when importing a template as YAML in the web console then clicking "Back" in the wizard, the "Next" button would stop working. The problem has been fixed so that the "Next" button works correctly after clicking "Back" in the "Import YAML" dialog.
Clone Of:
: 1530507 (view as bug list)
Environment:
Last Closed: 2018-01-23 17:59:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0113 normal SHIPPED_LIVE OpenShift Container Platform 3.7 and 3.6 bug fix and enhancement update 2018-01-23 22:55:59 UTC

Description shahan 2017-12-15 02:23:29 UTC
Description of problem:
 cannot continue to process template once back to initial page  from 'Import YAML/JSON'
 
Version-Release number of selected component (if applicable):
 v3.8.18

How reproducible:
Always

Steps to Reproduce:
1. Goto overview page, click 'Add to Project'->'Import YAML/JSON'
2. Browse template json/yaml file, Then click 'Create' and 'Continue' to 'Process the template',
3. Click 'Back' on the 'Template Configuration' step
4. Then click 'Create' and 'Continue' to 'Process the template' again.

Actual results:
4. cannot continue to process template, no response when clicking 'Continue' button.

Expected results:
4. should process template successfully.

Additional info:

Comment 1 Samuel Padgett 2017-12-15 14:37:09 UTC
I can reproduce.

Comment 2 Samuel Padgett 2017-12-15 15:38:07 UTC
master branch PR: https://github.com/openshift/origin-web-console/pull/2600

Comment 3 openshift-github-bot 2017-12-15 15:40:15 UTC
Commits pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/82397bdd1a81c75f194442b46662b50d999488db
Bug 1526215 - Fix back button behavior in Import YAML dialog

Clicking back from the "Template Configuration" step can prevent the
user from being able to click next again in the wizard in the Import
YAML dialog. This is because the `ctrl.currentStep` value is not reset
to the first step title after the user clicks back. Sine the wizard is
watching for changes to `ctrl.currentStep` and the value never changes
when the user clicks next again, the wizard doesn't advance.

Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1526215

https://github.com/openshift/origin-web-console/commit/ed2804e5c9872d176b6225cfcd85e0f7916b6200
Merge pull request #2600 from spadgett/import-yaml-current-step

Automatic merge from submit-queue.

Bug 1526215 - Fix back button behavior in Import YAML dialog

Clicking back from the "Template Configuration" step can prevent the
user from being able to click next again in the wizard in the Import
YAML dialog. This is because the `ctrl.currentStep` value is not reset
to the first step title after the user clicks back. Sine the wizard is
watching for changes to `ctrl.currentStep` and the value never changes
when the user clicks next again, the wizard doesn't advance.

Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1526215

/kind bug
/assign @benjaminapetersen

Comment 4 Samuel Padgett 2017-12-15 21:50:36 UTC
3.7 PR: https://github.com/openshift/origin-web-console/pull/2604

Comment 6 shahan 2018-01-03 07:12:47 UTC
Checked this issue on the OCP v3.7.16, it had been fixed, Changed status to Verified.

Comment 9 errata-xmlrpc 2018-01-23 17:59:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0113


Note You need to log in before you can comment on or make changes to this bug.