Bug 1526363 - [RHEL 7] high memory usage by glusterd on executing gluster volume set operations
[RHEL 7] high memory usage by glusterd on executing gluster volume set operat...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity high
: ---
: RHGS 3.3.1 Async
Assigned To: Mohit Agrawal
Ambarish
: ZStream
Depends On: 1522833
Blocks: 1527551
  Show dependency treegraph
 
Reported: 2017-12-15 04:38 EST by Sunil Kumar Acharya
Modified: 2018-01-10 21:46 EST (History)
12 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-52.1
Doc Type: Bug Fix
Doc Text:
Executing gluster volume set operations on volumes from gluster CLI caused a significant memory leak in glusterd process. The memory leak issues have been fixed in this release.
Story Points: ---
Clone Of: 1522833
: 1527551 (view as bug list)
Environment:
Last Closed: 2018-01-10 21:46:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Ambarish 2017-12-28 02:25:49 EST
Created 300 Dist Rep volumes.

Set volume options in loop .

EXACT COMMANDS  : for i in {1..300};do gluster v set butcher$i cluster.self-heal-daemon off;sleep 3 ;gluster v set butcher$i group metadata-cache;sleep 3;gluster v set butcher$i cluster.lookup-optimize on;sleep 3 ;done


** BEFORE VOL SET COMMANDS **
[root@gqas013 ~]# ps aux|grep /sbin/glusterd
root     17167  1.1  0.2 600724 109656 ?       Ssl  09:01   1:22 /usr/sbin/glusterd -p /var/run/glusterd.pid --log-level INFO
[root@gqas013 ~]#




** AFTER 300*3 VOL SET COMMANDS **:


[root@gqas013 ~]# ps aux|grep sbin/glusterd
root     17167  4.7  0.3 797332 118236 ?       Ssl  09:01  38:37 /usr/sbin/glusterd -p /var/run/glusterd.pid --log-level INFO



Memory consumption increased from 109 MB with a  small delta, 118 MB.


The same test was tried thrice.


Mem consumption of glusterd seemed controlled.


I am moving this bug to Verified.
Comment 12 errata-xmlrpc 2018-01-10 21:46:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0083

Note You need to log in before you can comment on or make changes to this bug.