Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1527551 - [RHEL 6] high memory usage by glusterd on executing gluster volume set operations
[RHEL 6] high memory usage by glusterd on executing gluster volume set operat...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity high
: ---
: RHGS 3.3.1 Async
Assigned To: Atin Mukherjee
Ambarish
: ZStream
Depends On: 1522833 1526363
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-19 08:40 EST by Atin Mukherjee
Modified: 2018-01-10 21:52 EST (History)
13 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-52.1
Doc Type: Bug Fix
Doc Text:
Executing gluster volume set operations on volumes from gluster CLI caused a significant memory leak in glusterd process. The memory leak issues have been fixed in this release.
Story Points: ---
Clone Of: 1526363
Environment:
Last Closed: 2018-01-10 21:52:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0084 normal SHIPPED_LIVE glusterfs bug fix update 2018-01-11 02:52:11 EST

  None (edit)
Comment 6 Ambarish 2017-12-29 04:22:43 EST
I don't see a significant increase in memory consumption by glusterd during repeated vol set operations on RHEL 6 nodes as well.

** BEFORE VOL SET,POST CREATION OF 300 VOLUMES** : 

[root@gqas001 ~]# ps aux|grep sbin/glusterd
root     13643  1.1  0.1 590480 110624 ?        Ssl  Dec28   0:48 /usr/sbin/glusterd --pid-file=/var/run/glusterd.pid

**AFTER 300*3 VOL SET COMMANDS *

[root@gqas001 ~]# ps aux|grep sbin/glusterd
root     13643 12.8  0.1 656020 115732 ?        Ssl  Dec28  22:07 /usr/sbin/glusterd --pid-file=/var/run/glusterd.pid


glustershd is still a problem , but that's being addressed by https://bugzilla.redhat.com/show_bug.cgi?id=1529501

I am moving this to Verified , since the delta is reasonable and is far better than what it was in 3.3.1 Gold.
Comment 9 errata-xmlrpc 2018-01-10 21:52:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0084

Note You need to log in before you can comment on or make changes to this bug.