Bug 1526371 - clean up port map on brick disconnect
Summary: clean up port map on brick disconnect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.3
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.3.1 Async
Assignee: Atin Mukherjee
QA Contact: Ambarish
URL:
Whiteboard:
Depends On: 1503244 1503246 1507747 1507749
Blocks: 1530512
TreeView+ depends on / blocked
 
Reported: 2017-12-15 09:56 UTC by Sunil Kumar Acharya
Modified: 2018-01-11 02:46 UTC (History)
12 users (show)

Fixed In Version: glusterfs-3.8.4-52.1
Doc Type: Bug Fix
Doc Text:
The portmap entry allocation that glusterd maintains for each of its brick is cleaned up on a graceful shutdown of the respective brick processes. In case a brick process was killed through SIGKILL signal or crashed, glusterd will not clean up the respective portmap entry allocation and after restarting the same brick glusterd may end up having two portmap allocations for the same brick.glusterd reports with a stale port to the client, resulting failure in connection. With this fix, the stale port entry is removed even for a brick crash or SIGKILL event of a brick process. The client now successfully connects to the brick after the brick is restarted.
Clone Of: 1503244
: 1530512 (view as bug list)
Environment:
Last Closed: 2018-01-11 02:46:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0083 normal SHIPPED_LIVE glusterfs bug fix update 2018-01-11 07:46:21 UTC

Comment 8 Ambarish 2018-01-03 08:37:29 UTC
Unable to reproduce the issue on 331_async.


**TEST STEPS** :





[root@gqas001 /]# ps -ef|grep glus
root       515     1  0 07:30 ?        00:00:00 /usr/sbin/glusterfsd -s gqas001.sbu.lab.eng.bos.redhat.com --volfile-id butcher.gqas001.sbu.lab.eng.bos.redhat.com.bricks1-A1 -p /var/run/gluster/vols/butcher/gqas001.sbu.lab.eng.bos.redhat.com-bricks1-A1.pid -S /var/run/gluster/6a74476cb867d30c8ccbb3fb03bc5141.socket --brick-name /bricks1/A1 -l /var/log/glusterfs/bricks/bricks1-A1.log --xlator-option *-posix.glusterd-uuid=0ea806f4-e798-4daf-8c3b-8891002b3839 --brick-port 49153 --xlator-option butcher-server.listen-port=49153
root       538     1  0 07:30 ?        00:00:00 /usr/sbin/glusterfs -s localhost --volfile-id gluster/glustershd -p /var/run/gluster/glustershd/glustershd.pid -l /var/log/glusterfs/glustershd.log -S /var/run/gluster/5d88e7a8c6588a66bceee8180ced8795.socket --xlator-option *replicate*.node-uuid=0ea806f4-e798-4daf-8c3b-8891002b3839
root       604 26054  0 07:30 pts/0    00:00:00 grep --color=auto glus
root     32103     1  0 07:19 ?        00:00:00 /usr/sbin/glusterd -p /var/run/glusterd.pid --log-level INFO
[root@gqas001 /]# 
[root@gqas001 /]# 

[root@gqas001 /]# 
[root@gqas001 /]# 
[root@gqas001 /]# kill -9 515
[root@gqas001 /]# 

[root@gqas001 /]# 
[root@gqas001 /]# gluster v start butcher force
volume start: butcher: success
[root@gqas001 /]# 



[root@gqas001 /]# ps -ef|grep glus
root       648     1  0 07:31 ?        00:00:00 /usr/sbin/glusterfsd -s gqas001.sbu.lab.eng.bos.redhat.com --volfile-id butcher.gqas001.sbu.lab.eng.bos.redhat.com.bricks1-A1 -p /var/run/gluster/vols/butcher/gqas001.sbu.lab.eng.bos.redhat.com-bricks1-A1.pid -S /var/run/gluster/6a74476cb867d30c8ccbb3fb03bc5141.socket --brick-name /bricks1/A1 -l /var/log/glusterfs/bricks/bricks1-A1.log --xlator-option *-posix.glusterd-uuid=0ea806f4-e798-4daf-8c3b-8891002b3839 --brick-port 49152 --xlator-option butcher-server.listen-port=49152
root       670     1  0 07:31 ?        00:00:00 /usr/sbin/glusterfs -s localhost --volfile-id gluster/glustershd -p /var/run/gluster/glustershd/glustershd.pid -l /var/log/glusterfs/glustershd.log -S /var/run/gluster/5d88e7a8c6588a66bceee8180ced8795.socket --xlator-option *replicate*.node-uuid=0ea806f4-e798-4daf-8c3b-8891002b3839
root       735 26054  0 07:31 pts/0    00:00:00 grep --color=auto glus
root     32103     1  0 07:19 ?        00:00:00 /usr/sbin/glusterd -p /var/run/glusterd.pid --log-level INFO
[root@gqas001 /]# 



Moving to Verified.

Comment 11 errata-xmlrpc 2018-01-11 02:46:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0083


Note You need to log in before you can comment on or make changes to this bug.