Bug 1527389 - [3.6] Nodes becomes NotReady, when status update connection is dropped/severed to master, causing node to wait on 15min default net/http timeout before trying again.
Summary: [3.6] Nodes becomes NotReady, when status update connection is dropped/severe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.6.z
Assignee: Maciej Szulik
QA Contact: Wang Haoran
URL:
Whiteboard:
: 1543086 (view as bug list)
Depends On: 1464653
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-19 10:37 UTC by Nicolas Nosenzo
Modified: 2018-04-12 06:00 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Rate limiting is causing some connection to master from node to be dropped. Consequence: Node status is not updated properly. Fix: Use a separate (non-limited) client for node status. Result: The node status should be properly saved in the master.
Clone Of: 1464653
Environment:
Last Closed: 2018-04-12 05:59:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1106 None None None 2018-04-12 06:00:45 UTC

Comment 11 Maciej Szulik 2018-03-08 10:15:02 UTC
*** Bug 1543086 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2018-04-12 05:59:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1106


Note You need to log in before you can comment on or make changes to this bug.