Bug 1527876 - FC deployment with node zero fails with [ ERROR ] ERROR! the playbook: /usr/share/ovirt-hosted-engine-setup/ansible/fc_getdevices.yml could not be found.
Summary: FC deployment with node zero fails with [ ERROR ] ERROR! the playbook: /usr/s...
Keywords:
Status: CLOSED DUPLICATE of bug 1527135
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Setup.Core
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks: 1455169
TreeView+ depends on / blocked
 
Reported: 2017-12-20 10:17 UTC by Nikolai Sednev
Modified: 2017-12-21 08:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-21 08:39:44 UTC
oVirt Team: Integration


Attachments (Terms of Use)

Description Nikolai Sednev 2017-12-20 10:17:25 UTC
Description of problem:
Separating with by this bug from https://bugzilla.redhat.com/show_bug.cgi?id=1455169#c9.

FC deployment with node zero fails with [ ERROR ] ERROR! the playbook: /usr/share/ovirt-hosted-engine-setup/ansible/fc_getdevices.yml could not be found.

I'm getting these during FC deployment with node zero:
[ INFO  ] TASK [Remove host-deploy configuration file]
[ INFO  ] changed: [localhost]
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: fc
[ INFO  ] Getting Fibre Channel LUNs list
[ ERROR ] ERROR! the playbook: /usr/share/ovirt-hosted-engine-setup/ansible/fc_getdevices.yml could not be found
         
[ ERROR ] Unable to get target list
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]:

[root@purple-vds2 ~]# ll -lsh /usr/share/ovirt-hosted-engine-setup/ansible/
total 44K
 12K -rw-r--r--. 1 root root 8.3K Dec 14 17:47 bootstrap_local_vm.yml
   0 drwxr-xr-x. 2 root root   77 Dec 18 17:00 callback_plugins
4.0K -rw-r--r--. 1 root root 1.1K Dec 14 17:47 clean_environment.yml
8.0K -rw-r--r--. 1 root root 5.2K Dec 14 17:47 create_storage_domain.yml
 12K -rw-r--r--. 1 root root  12K Dec 14 17:47 create_target_vm.yml
4.0K -rw-r--r--. 1 root root  588 Dec 14 17:47 iscsi_discover.yml
4.0K -rw-r--r--. 1 root root 1.2K Dec 14 17:47 iscsi_getdevices.yml
   0 drwxr-xr-x. 2 root root  104 Dec 18 17:00 library
   0 drwxr-xr-x. 2 root root  249 Dec 18 17:00 templates


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Deploy SHE over FC using ansible deployment.

Actual results:
[ ERROR ] ERROR! the playbook: /usr/share/ovirt-hosted-engine-setup/ansible/fc_getdevices.yml could not be found   
[ ERROR ] Unable to get target list

Expected results:
Deployment should succeed.

Additional info:

Comment 1 Yaniv Kaul 2017-12-21 07:37:05 UTC
https://gerrit.ovirt.org/#/c/85558/ fixed it - isn't this a dup of bug 1527135 ?

Comment 2 Nikolai Sednev 2017-12-21 08:39:44 UTC
(In reply to Yaniv Kaul from comment #1)
> https://gerrit.ovirt.org/#/c/85558/ fixed it - isn't this a dup of bug
> 1527135 ?

You're correct, my bad, opened it after Martin asked me to open a separate bug for FC issue, and I forgot that I already had opened it in bug 1527135.

*** This bug has been marked as a duplicate of bug 1527135 ***


Note You need to log in before you can comment on or make changes to this bug.