Bug 152858 - up2date does not handle apt-mirror's
up2date does not handle apt-mirror's
Status: CLOSED DUPLICATE of bug 106123
Product: Fedora Legacy
Classification: Retired
Component: General (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 18:53 EST by William M. Quarles
Modified: 2007-04-18 13:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 13:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2005-03-30 18:29:57 EST
This bug is listed as Fedora Core 2 on the Red Hat Bugzilla, but I think that it
might be affecting Fedora Core 1 as well.  I've been experiencing similar
problems to what this person has described on the Fedora Developers' mailing
list when using the Planet CCRMA repositories
<http://ccrma.stanford.edu/planetccrma/software/>.  His original message does
not seem to be in the archives yet, but here it is copy-and-pasted from the
gmane newsgroup.

****

-------- Original Message --------
From: Jos Vos <jos@xos.nl>
Subject: APT repository problems with up2date
Newsgroups: gmane.linux.redhat.fedora.devel

Hi,

Before I start digging in the up2date code myself, maybe someone
can comment on this:

I have a problem when using up2date up2date with my self-created
APT repositories.  When updating, it complains about conflicting
files: it just thinks that a long list of directories that are
shared among packages conflict with each other.

Apt-get itself (and synaptic) seems to work fine with the same
repository, only with up2date there is a problem.  Also, up2date
with a yum repository of then same package set works fine, as
does yum itself.

FWIW: I generate my APT repositories with --flat --bloat.

Cheers,

--
--    Jos Vos <jos@xos.nl>
--    X/OS Experts in Open Systems BV   |   Phone: +31 20 6938364
--    Amsterdam, The Netherlands        |     Fax: +31 20 6948204


-- 
fedora-devel-list mailing list
fedora-devel-list@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-devel-list

****

However, my tests have shown that the same problems exist when accessing both
the Yum and APT repositories on this site using Up2Date, so I am not certain of
the exact cause of these errors.  However, both APT and Yum seem to work fine
without bringing up these irrelevant "file conflicts," so it would seem that
either Up2Date has bugs or is otherwise very picky about how the repository
headers describe the packages.  Since Up2Date has not been well documented
(release notes only) since the addition of Yum and APT capabilities, and I don't
think that the developers really know what to do either since they are not
saying anything on the list about it, I really didn't know what else to do other
than bring up this person's findings and his patch on The Fedora Legacy
Project's Bugzilla.



------- Additional Comments From quarlewm@jmu.edu 2004-11-27 21:13:35 ----

Someone on the Fedora Developer's list finally pointed out another bug report
that covers the same issue.  I'm trying to get communication between the two
reports going.

<https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=106123>



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:29 -------

This bug previously known as bug 2306 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=2306
Originally filed under the Fedora Legacy product and General component.

Unknown priority P3. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
Unknown severity blocker. Setting to default severity "normal".
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Matthew Miller 2005-04-12 13:50:45 EDT
This is outside of the scope of Fedora Legacy. However, bug #106123 deals with
this for FC devel -- marking duplicate.

*** This bug has been marked as a duplicate of 106123 ***

Note You need to log in before you can comment on or make changes to this bug.