Bug 152927 - dead keys don't work
dead keys don't work
Status: CLOSED DUPLICATE of bug 130851
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 18:40 EST by Felipe Heidrich
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-04 02:34:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Heidrich 2005-03-30 18:40:13 EST
dead keys don't work on my FC3, running on Gnome.

I set my keyboard to brazilian ABNT2, does not matter if I use system-config-
keyboard or setxkbmap to do the work. I type ' ` " ^ and nothing happens. ' 
followed e gives me e instead of é.
I also tried different keyboard layouts (german, english internatinal), I 
could not get dead keys to work.

So I changed my system to run IIIM on level 5, put the new input method 
switcher up in the bottom panel. Using that I set my input to Latin (unitle), 
now when I hit ' it opens a floating window with a list of option. This is 
horrible, my whole life I used ' followed by e to get é, now I suppose to 
hit ', wait a list to come up, then type the number of the option I want. Even 
worse, the option I want (é) is not in the list!

That is how input method is supposed to work now ? I'm missing something 
simple ?

Thanks
Comment 1 Leon Ho 2005-03-31 01:40:52 EST
Will deadkeys work again if you stop the iiim service? If yes that is duplicate
of bug 130851.

*** This bug has been marked as a duplicate of 130851 ***
Comment 2 Felipe Heidrich 2005-03-31 11:51:24 EST
No, it will not.
Comment 3 Akira TAGOH 2005-04-01 01:43:02 EST
Erm, so even if you did service iiim stop as root, the dead key still doesn't
work? It sounds like you have a problem in xorg.conf. and this isn't an IIIMF
bug since this problem happened without IIIMF.
Comment 4 Felipe Heidrich 2005-04-01 13:07:44 EST
I got dead keys to work on X/Motif/GTK. I had to stop the iiim server and 
unset GTK_IM_MODULE and XMODIFIERS.
You can close this as dup of bug130851

Comment 5 Akira TAGOH 2005-04-04 02:34:10 EDT
Thank you for your confirmation. closing.

*** This bug has been marked as a duplicate of 130851 ***

Note You need to log in before you can comment on or make changes to this bug.