Bug 130851 - iiimf eats European dead keys
Summary: iiimf eats European dead keys
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: im-sdk   
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords: i18n
: 152927 (view as bug list)
Depends On:
Blocks: IIIMF 156322 163944
TreeView+ depends on / blocked
 
Reported: 2004-08-25 09:59 UTC by Carl-Johan Kjellander
Modified: 2007-11-30 22:07 UTC (History)
9 users (show)

Fixed In Version: RHBA-2005-683
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 16:43:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script for launching gedit (and only gedit) with Japanese input (155 bytes, text/plain)
2005-02-19 13:54 UTC, David Monniaux
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:683 qe-ready SHIPPED_LIVE im-sdk bug fix update 2005-10-05 04:00:00 UTC

Description Carl-Johan Kjellander 2004-08-25 09:59:43 UTC
Description of problem:
After trying adding "XIM=htt" to ~/.i18n to get
gnome-im-switcher-applet to work, as said in Bug #113922,
the im-switcher runs fine but now dead keys on a swedish
keyboard layout doesn't work anymore.

Version-Release number of selected component (if applicable):
iiimf-gtk-11.4-46.1.svn1587
xorg-x11-6.7.0-5

How reproducible:
Always

Steps to Reproduce:
1. Add "XIM=htt" to ~/.i18n or global i18n-file
2. Log in and out from gnome.
3. Add gnome-im-switcher-applet to panel and play with that.
4. setxkbmap se
  
Actual results:
Dead keys don't work. ¨, ^ and ~ act as if they are dead but
nothing is produced. ~ + space outputs ' ', ¨ + a outputs 'a'.

Expected results:
Dead keys should work. ~ + space output '~', ¨ + a output 'ä'.

Additional info:
I have input all these characters with 'setxkblayout se nodeadkeys'
since I can't input them with the dead keys anymore.

¨, ^ and ~ are on the key right of ] on a swedish keyboard.

Comment 1 Jens Petersen 2004-08-31 03:35:37 UTC
Carl, which LE (Language Engine) are you using?

Comment 2 Carl-Johan Kjellander 2004-08-31 08:35:01 UTC
Japanese.


Comment 3 Carl-Johan Kjellander 2004-08-31 08:50:32 UTC
And I just realised another problem. If NumLock is pressed,
the arrowkeys stop working, along with CTRL-Space not working,
so you can't change input mode.

I'm not sure I can reproduce the arrowkeys thing, maybe it
just happened once right now, and changing between 'se' and
'se nodeadkeys' fixed that. But the CTRL-Space thing is
100% reproducible.



Comment 4 Carl-Johan Kjellander 2004-09-01 09:47:22 UTC
Arrowkeys stopped working again last night.


Comment 5 Jens Petersen 2004-09-03 02:39:34 UTC
Any idea why?

Comment 6 Jens Petersen 2004-09-03 02:41:22 UTC
If you have a chance, could you test with the newer
im-sdk in rawhide - unfortunately you probably
need to rebuild it for it to work on fc2....

Comment 7 Carl-Johan Kjellander 2004-09-05 15:29:24 UTC
No ideas at all why these problems exist.

And it's actually not 'im-sdk' that is giving me problems, it's
iiimf-gtk or the japanese le, but you can't select those components
in bugzilla.


Comment 8 Jens Petersen 2004-09-16 14:32:28 UTC
Some fixes have been made to iiimf-le-canna very recently.
I suggest trying 12.0.1-5.svn1891 or later when they
appear in rawhide - should be a little after fc3 test2
is out.  Or it can be made available for testing sooner
if you wish.

Comment 9 Jens Petersen 2004-10-06 09:00:56 UTC
Reproduced - this seems to be a frontend bug: perhaps
in the gtk iiim im module and httx or the iiimcf libs perhaps.

Anyway the problem doesn't seem to be specific to canna LE -
I see it with Hangul LE too.

Comment 10 Yu Shao 2004-10-07 07:06:44 UTC
Carl, are you experiencing the same problem when you are using other
LEs like Chinese ones?

Comment 11 Carl-Johan Kjellander 2004-10-08 00:44:13 UTC
It's not just in Japanese, English is fucked up as well.

I'll try removing Japanese tomorrow and logging in and out,
and see if that does anything.

But I was having these problems in RH9 as well, and then I
did remove everything but English and still had the problems.

My guess is that it's not in the LEs, but the frontend or httx.  

Comment 12 Carl-Johan Kjellander 2004-10-08 13:41:25 UTC
I've now tried with Japanese, Simplified Chinese and without anything
but English, and the bug is still there.

Here is the output from xev when pressing ALTGR-~

KeyPress event, serial 25, synthetic NO, window 0x3c00001,
    root 0x48, subw 0x0, time 832362429, (1111,934), root:(1116,956),
    state 0x10, keycode 113 (keysym 0xfe03, ISO_Level3_Shift),
same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False
 
KeyPress event, serial 28, synthetic NO, window 0x3c00001,
    root 0x48, subw 0x0, time 832362610, (1111,934), root:(1116,956),
    state 0x90, keycode 35 (keysym 0xfe53, dead_tilde), same_screen YES,
    XLookupString gives 1 bytes: (7e) "~"
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: True
 
KeyRelease event, serial 28, synthetic NO, window 0x3c00001,
    root 0x48, subw 0x0, time 832362748, (1111,934), root:(1116,956),
    state 0x90, keycode 35 (keysym 0xfe53, dead_tilde), same_screen YES,
    XLookupString gives 1 bytes: (7e) "~"
 
KeyRelease event, serial 28, synthetic NO, window 0x3c00001,
    root 0x48, subw 0x0, time 832363215, (1111,934), root:(1116,956),
    state 0x90, keycode 113 (keysym 0xfe03, ISO_Level3_Shift),
same_screen YES,
    XLookupString gives 0 bytes:
 


Comment 13 Giuseppe Castagna 2004-11-15 11:41:24 UTC
I reproduced this bug also with U.S. English keyboard layouts with
dead keys.

Comment 14 Jens Petersen 2004-11-17 13:34:46 UTC
ISO_Level3_Shift seems to work fine but not the deadkeys as you observe.

Comment 15 Yu Shao 2004-11-18 00:38:54 UTC
Based on the conversion with Hideki on mailing list, UNIT should be
the one to input European characters. Carl-Johan, are you ok with UNIT?

Comment 16 Carl-Johan Kjellander 2004-11-18 02:17:20 UTC
I don't have UNIT as a language in my version.
Should I try and upgrade to fc3?

Comment 17 Jens Petersen 2004-11-18 02:34:47 UTC
Well, I think you just need to install iiimf-le-unit, but
I not sure how complete the Latin LEs coverage is.  Testing
would be very welcome.  There are many improvements in iiimf
in fc3 though so I would encourage you to try to upgrade
to that anyway.

However Hideki also said that we probably need an intermediate
solution for the problem: ie allowing the deadkeys to work normally
when iiimf is in the off state.

Comment 18 Yu Shao 2004-11-18 02:46:01 UTC
yeah, try latest im-sdk, use unitle, when press dead keys, you will
see a candidate window of the accented characters.

Comment 19 Jens Petersen 2004-11-18 03:07:16 UTC
Actually you're right, Yu, I hadn't tried using PageUp and PageDn
on the candidate window: it seems to have all the major chars for
both dead_acute and dead_grave at least.  I didn't try other types
of deadkey but assume they work too.

/me who would like to know how to input Danish vowels with a jp
keyboard with iiimf...  Probably a separate bug is needed for that.

I guess one could still argue though that supporting deadkeys
when iiimf is off would be a good thing though.

Comment 20 Giuseppe Castagna 2004-11-18 11:40:14 UTC
> yeah, try latest im-sdk, use unitle, when press dead keys, you will
> see a candidate window of the accented characters.

Ahem, I have fc3 and installed rawhide version of iiimf (12.1-8). I
installed unit-le and restarted iiimf services but dead keys are still
dead (no resurrection ;-) When I select US keyboard with dead keys and
press a dead key nothing is printed and the next charecter is then
displayed not modified. Where am I wrong?

> I guess one could still argue though that supporting deadkeys
> when iiimf is off would be a good thing though.

Definitively. This is at least my case and I am not the only one.
I have a US keyboard, write in English 60% of my text, in French 39%
and japanese 1%. So I really need to use dead keys to write french
accents on my US keyboard. Let me know how I can help.

-------------------
P.S. What ISO_Level3_Shift is?


Comment 21 Jens Petersen 2004-11-18 12:15:23 UTC
Giuseppe, the deadkeys only work with iiimf with the Latin LE
(Latin -> unitLE in the gimlet lang menu) when it is on.

However I can only get dead_acute and dead_grave to work with it
even though the Latin LE table in the source seems to contain
many more symbols.

ISO_Level3_Shift is normally bound to Alt_R (AltGR), the modifier
for getting the symbols written on the right side of the keys.

Comment 22 Giuseppe Castagna 2004-11-18 13:29:46 UTC
> Giuseppe, the deadkeys only work with iiimf with the Latin LE
> (Latin -> unitLE in the gimlet lang menu) when it is on.
> 

Ahhh, I did  not have noticed that now in the Gimlet submenu now Latin
had another submenu unitle. I selected it and now I have my accents.
However the reason why I did not notice it is that when I am in
Thunderbird (or Firefox) there is not such a submenu. I think that
this is normal, howver the consequence is that I cannot use dead-keys
(hence, accents) in my main mail-client (Thunderbird). It would be
wonderful if one could use dead-keys even without passing through iiimf.

In any case thanks a lot.

> However I can only get dead_acute and dead_grave to work with it
> even though the Latin LE table in the source seems to contain
> many more symbols.
> 

Yes the same here. This is mostly ok for French (apart from ^ over
several letters). More annoying is for Spanish since ~ over n is no
longer possible.


> ISO_Level3_Shift is normally bound to Alt_R (AltGR), the modifier
> for getting the symbols written on the right side of the keys.
> 

Thanks


Comment 23 Giuseppe Castagna 2004-11-18 14:16:17 UTC
Just an additional indication. I do not know whether this is
a bug or not, but when I select the greek input mode (I use it
for mathematical symbols) gimlet still indicates "En"

Comment 24 Jens Petersen 2004-11-19 02:40:27 UTC
Comment 22: the current default gimlet lang selection behaviour
for new apps may be a little confusing, but I'd be surprised if
Latin -> unitLE isn't there once you've added it...
You may want to try gnome-im-properties...

Comment 23: For me it shows "El" for Greek.

Comment 25 Samuel Audet 2004-11-20 03:42:32 UTC
Until this problem gets resolved, you can use this trick which I have
been using for the past 3 years... When I want to type in Japanese, I
start my applications with this script:

#!/bin/sh

export XMODIFIERS="@im=htt"
export LANG=ja_JP.UTF-8
export GTK_IM_MODULE="iiim"
httx &
sleep 1
$@

So, the other way around, if one unsets GTK_IM_MODULE and XMODIFIERS,
the launching application will not use the input modifier and will
work fine with dead keys.

Comment 26 Giuseppe Castagna 2004-11-20 09:21:05 UTC
> Comment 22: the current default gimlet lang selection behaviour
> for new apps may be a little confusing, but I'd be surprised if
> Latin -> unitLE isn't there once you've added it...
> You may want to try gnome-im-properties...
> Comment 23: For me it shows "El" for Greek.

This happened because I had just restarted the iiimf service and
noot rebooted the machine. After rebooting both problems vanished. 


Comment 27 Jens Petersen 2004-11-21 23:32:53 UTC
Giuseppe, ok, it sounds like gimlet was out of sync then.
If you have a way to reproduce that, please file another bug.

Comment 28 Jens Petersen 2004-11-30 14:01:47 UTC
Adding patch from trunk to fix deadkeys in Euro layout at least.

Comment 29 Yu Shao 2004-12-06 07:54:47 UTC
As using UNIT LE is the way suggested from upstream, how does UNIT
works for everyone?

Comment 30 Mike Sowka 2004-12-08 02:21:59 UTC
All these fancy shmancy frameworks... I consider myself quite
proficient in linux use etc., but it took me the WHOLE day to figure
out how to write in polish and french (in addtion to my en_CA default
local). And as such I would like to help as best as I can with this bug...

#1 For polish I finally realized that there is no PL support in iiimf
and I just need to switch keyboard layout. That worked fine...
'COMPLAINT': how do we get PL into iiimf?

#2 For my french, US-intl keyboard + iiimf-le-unit seem to work 90%.
That is, as mentioned above, only dead_acute and dead_grave work.

I've got FC3 installed here, with no non-stable RPMS. Is there a
workaround to the limited dead-key functionality in iiimf-le-unit...
and can contribute in any way to have a simply-working langauge input
switcher "widget"?

Thanks, (sorry for the rant, it's been a looong day beating on this)
Mike



Comment 31 Mike Sowka 2004-12-08 02:35:55 UTC
... before I leave this alone for good (for the day). A couple more
things to add:

- Ctrl-Space/Shift-Space does not work consistently. read: it appears
that I first have to make a change in gimlet, and then after the
initial setting of le the keyborad shortcuts work to switch from the
default to the chosen le

- how do I delete the Latin->default, as this le is quite ?useless?
and I would like Latin->unitle to be the default iiimf input engine

That's _IT_ for the day (for real this time),
Stubborn Mike

Comment 32 Jens Petersen 2004-12-09 06:04:57 UTC
Mike,

In response to comment 30:

#1 Right as you state keyboard layouts and iiimf are not yet
integrated.  I'm not familiar with Polish layout, but do you
actually need a full Polish layout or would you be happy with
just being able to input Polish characters with some LE in
iiimf?

#2 The other deadkeys should be working properly in 12.1-10
and later in rawhide (fc/development) - if you could test
that it would be appreciated.  (I think it should install/
work ok in fc3).

For comment 31:
It sounds like the first and second comment are the same?
You don't like Latin->default LE.  It is there primarily
for English users who only want to use really occasionally.

Could you file a separate bug about that: "can't remove
Latin->default LE"?  Thanks.

Comment 33 Mike Sowka 2004-12-09 14:43:44 UTC
Jens,

#1 You are right, after reading up on LE I realized that I have to use
a layout ONLY becuase an LE for polish just isn't available yet. If I
were  to look at this, would the idea be to just implement it into
le-unit? For now a layout w/ default LE works fine, i.e. use right-alt
for the funky accented characters ;) here is a sample Ä, Ä, Å, Ä, Å, ó
... in fact my _real_ name is MichaŠSówka :D

#2 I will install the rawhide packages and will report as soon as I
can rip myself away from my thesis work for long enough...

#3 Right again... I see You agree that it's a missing feature to be
able to remove a input method for a given language... will make sure
to follow up.

Doing what I can,
Mike

Comment 34 David Monniaux 2005-02-19 13:43:57 UTC
#29: unit_le from version 12.1/release 10.FC3 does *not* work correctly at all,
either for inputting accented Latin, either for Greek. See bug 149105.

Comment 35 David Monniaux 2005-02-19 13:54:16 UTC
Created attachment 111227 [details]
script for launching gedit (and only gedit) with Japanese input

This script can be used to launch a gedit (or any other program) with the
Japanese input method, without having to set us the whole desktop for Japanese
(and thus avoiding the global effect of removing Compose / dead keys).

Comment 36 Leon Ho 2005-03-31 06:40:58 UTC
*** Bug 152927 has been marked as a duplicate of this bug. ***

Comment 37 Akira TAGOH 2005-04-04 06:34:13 UTC
*** Bug 152927 has been marked as a duplicate of this bug. ***

Comment 39 Akira TAGOH 2005-04-19 07:49:28 UTC
Sorry for long delay, well, can you try the latest IIIMF packages in rawhide?
perhaps 12.1.1-15.svn2509 would makes it better for UNIT.  Please let us know
what's the problem in the latest.

Thanks,


Comment 43 Petr Tuma 2005-07-19 06:59:12 UTC
I am observing the problems described above for IIIMF-LE-CANNA and Czech
keyboard layout. I have tried the IIIMF-LE-UNIT language engine, but the result
is not satisfactory - only when I switch to Latin-Unitle do the dead keys work,
but then other strange things happen - such as when I type in a normal letter
after an accented one, it gets displayed twice.

As somebody above noted, the entire process of figuring things out with IIIMF is
terribly unintuitive and cumbersome - on this particular instance, could perhaps
an extra option be added to the Gnome Panel applet that would make it possible
to simply disable IIIMF for a given window ? After all, the keyboard layouts are
time tried and work well for most things ...

Using FC4 with the latest updates BTW.


Comment 44 Akira TAGOH 2005-07-20 10:45:21 UTC
Thank you for your feedback, Petr.

(In reply to comment #43)
> I am observing the problems described above for IIIMF-LE-CANNA and Czech
> keyboard layout. I have tried the IIIMF-LE-UNIT language engine, but the result
> is not satisfactory - only when I switch to Latin-Unitle do the dead keys work,
> but then other strange things happen - such as when I type in a normal letter
> after an accented one, it gets displayed twice.

I think it's Bug#162646 I've filed and will be fixed in next build -- it's now
being built -- could you please test this issue with the fixed packages again?

Thanks,

Comment 45 Akira TAGOH 2005-07-22 04:51:03 UTC
Ok, I've confirmed now that XKB doesn't work on IIIMF enabled. let me have a
look into it then.  However the latest UNIT LE looks good to me though, but anyway.

Comment 47 Akira TAGOH 2005-07-28 14:51:43 UTC
This problem should be fixed in 12.1-13.EL.2.

Comment 50 Red Hat Bugzilla 2005-10-05 16:43:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-683.html



Note You need to log in before you can comment on or make changes to this bug.