Bug 153014 - Installation problem - The Fedora Core CD was not found in any of your CDROM drives
Installation problem - The Fedora Core CD was not found in any of your CDROM ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
bzcl34nup
: Reopened
Depends On:
Blocks: FCMETA_INSTALL
  Show dependency treegraph
 
Reported: 2005-03-31 16:44 EST by Vladislav Staroselskiy
Modified: 2015-01-04 17:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 17:37:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of 4th console of Fedora Core 6 (270.03 KB, image/pjpeg)
2006-12-06 11:56 EST, Vladislav Staroselskiy
no flags Details

  None (edit)
Description Vladislav Staroselskiy 2005-03-31 16:44:20 EST
Description of problem:

Hardware-dependent problem. Gives "Fedora Core CD is not found" message, even 
if installer successfully booted from CD and ATAPI CDROM was successfully 
detected. 4th console gives the following message:
<4>hdc: media error (bad sector): status=0x51 { DriveReady SeekComplete Error
<4>hdc: media error (bad sector): error: 0x30
<4>ide: failed opcode was 100
<4>end_request: I/O error, dev hdc, error=0x30, sector 64
<4>isofs_fill_super: bread failed, dev=hdc, iso_biknum=16, block=16

This is NOT a CD media problem, since I tried to burn different CDs from 
different manufacturers with the same result.

Version-Release number of selected component (if applicable):
Server: IBM eServer xSeries 205, M/T 8480-33X
CD-ROM: LTN486S

-bash-3.00$ dmesg | grep hd
    ide0: BM-DMA at 0xa480-0xa487, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xa488-0xa48f, BIOS settings: hdc:DMA, hdd:DMA
hda: IC35L060AVV207-0, ATA DISK drive
hdc: LTN486S, ATAPI CD/DVD-ROM drive
hdd: Maxtor 2F040L0, ATA DISK drive
hda: max request size: 1024KiB
hda: 78156288 sectors (40016 MB) w/1821KiB Cache, CHS=16383/255/63, UDMA(100)
hda: cache flushes supported
 hda: hda1 hda2
hdd: max request size: 128KiB
hdd: 80293248 sectors (41110 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
hdd: cache flushes supported
 hdd: hdd1 hdd2 hdd3
hdc: ATAPI 48X CD-ROM drive, 120kB Cache, UDMA(33)

How reproducible:
Every time from any of 8 existing IBM xSeries 205 servers with the same 
hardware configuration. 

Steps to Reproduce:
1. Boot from Fedora Core 3 disk 1.
2. Answer on few installer questions about language and keyboard type. 
Choose "Local CDROM" when asked about source.
  
Actual results:
"The Fedora Core CD was not found in any of your CDROM drives" message.

Expected results:
Continue installation from CD, where system and installer booted from.

Additional info:
LTN486S CDROM was temporary swapped with another model (CR-852E), configured 
with the same settings, and successfully performed installation.

I am not certainly sure, what the category should I submit this problem to, it 
seems some of the drivers compiled into kernel, please, reassign it if 
necessary. Thanks.
Comment 1 George Davis 2005-05-02 19:43:26 EDT
Also a problem with FC2.  Appears to be a bug with the cd-roms on certain IBM
systems not just the servers.
Comment 2 Dave Jones 2005-07-15 16:33:28 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Vladislav Staroselskiy 2005-07-19 16:49:29 EDT
I have tried Fedora Core 4 - it has the same problem on mentioned hardware.
Comment 4 Dave Jones 2005-09-30 05:43:08 EDT
does booting with acpi=off make any difference ?
Comment 5 Vladislav Staroselskiy 2005-09-30 12:06:19 EDT
No, it doesn't.
Comment 6 Dave Jones 2005-09-30 19:50:08 EDT
http://fedora.isphuset.no/ contains an unofficial Fedora 4.1, which may get you
up and running, as it has a install kernel based on one of the errata kernels.
Comment 7 Vladislav Staroselskiy 2005-10-04 11:32:10 EDT
The problem still exists in 4.1. 

The message from 4th console contains slighly more details:

<4>hdc: media error (bad sector): status=0x51 { DriveReady SeekComplete Error
<4>hdc: media error (bad sector): error: 0x30 {LastFailedSense=0x03 }
<4>ide: failed opcode was: unknown
<3>ATAPI device hdc:
<4>  Error: Medium error -- (Sense key=0x03)
<3>  (reserved error code) -- (asc=0x02, ascq=0x00)
<3>  The failed "Read 10" packet command was:
<4>  "28 00 00 00 00 10 00 00 01 00 00 00 00 00 00 00 "
<4>end_request: I/O error, dev hdc, sector 64
<4>isofs_fill_super: bread failed, dev=hdc, iso_biknum=16, block=16
Comment 8 Stian Stryni 2005-10-17 04:34:23 EDT
booting with ide=nodma worked for me on an IBM NetVista.

Without option:

- No media check
- Remains in textmodus.
- choose language
- choose keyboard
- "Fedore Core CD not found..."

With option:
- Media check
- Starts graphical installation.
- OK.
Comment 9 Vladislav Staroselskiy 2005-10-18 12:11:41 EDT
I confirm, that "ide=nodma" option works for IBM xSeries 205 as well. 
It seems this problem is related to DMA.
Comment 10 Dave Jones 2005-11-10 15:19:30 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 11 Dave Jones 2005-11-19 04:04:47 EST
Due to the overhead involved in creating new ISOs (which is what would be
required for fixing bugs seen at installation time that don't have workarounds),
this bug has been closed.

For more information and suggestions, please see bug 169613

Thanks.
Comment 12 Vladislav Staroselskiy 2006-04-28 14:54:53 EDT
The problem still exists in Fedora Core 5.
Comment 13 Adam 2006-06-26 20:16:01 EDT
Same problem here on Core 4 and Core 5. I have an IBM 8668-44X eServer.
Comment 14 Daniel Hawton 2006-10-05 11:00:27 EDT
Same problem here on Core 5, ide=nodma doesn't fix it.
Comment 15 Dave Jones 2006-10-16 20:17:30 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 16 Vladislav Staroselskiy 2006-10-17 14:17:25 EDT
If you let me know how to alter a kernel on FC5 bootable installation CD - I 
will do that, otherwise I will wait for a new FC (pre)release and will retest 
it then.

Thank you.
Comment 17 Dave Jones 2006-10-20 21:50:06 EDT
The Fedora Unity project (www.fedoraunity.org) does respins of older releases
with newer kernels from time to time. If this did get fixed, then its possible
that media will work for you.

Comment 18 Vladislav Staroselskiy 2006-12-06 11:56:27 EST
Created attachment 142966 [details]
Screenshot of 4th console of Fedora Core 6
Comment 19 Vladislav Staroselskiy 2006-12-06 12:00:02 EST
Fedora Core 6 still has the same problem. I have attached a screenshot of 4th 
console. As mentioned above, it boots fine with "ide=nodma" option.
Comment 20 Bug Zapper 2008-04-03 21:55:33 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 21 Vladislav Staroselskiy 2008-04-25 17:37:54 EDT
Impossible to test, since FC8 is currently distributed on DVD media, while
specific servers have CDROM's with no DVD compatibility.

Please, close this ticket.

Note You need to log in before you can comment on or make changes to this bug.