Bug 153039 - GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
GtkDeprecationWarning: gtk.FALSE, gtk.TRUE
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Phil Knirsch
:
: 145569 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-03-31 22:54 EST by Ricky Ng-Adam
Modified: 2015-03-04 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-23 08:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricky Ng-Adam 2005-03-31 22:54:17 EST
Description of problem:

/usr/share/system-config-httpd/ApacheConf.py:1041: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  xml.get_widget ("edit_address_button").set_sensitive (FALSE)
/usr/share/system-config-httpd/ApacheConf.py:1042: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  xml.get_widget ("delete_address_button").set_sensitive (FALSE)
/usr/share/system-config-httpd/ApacheConf.py:1043: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  xml.get_widget ("edit_vhost_button").set_sensitive (FALSE)
/usr/share/system-config-httpd/ApacheConf.py:1044: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  xml.get_widget ("delete_vhost_button").set_sensitive (FALSE)
/usr/share/system-config-httpd/ApacheConf.py:1059: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_reorderable (TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1061: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_column_auto_resize (0, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1062: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_column_auto_resize (1, TRUE)
/usr/share/system-config-httpd/CheckList.py:12: DeprecationWarning: use gtk.TreeView
  CList.__init__ (self, 2)
/usr/share/system-config-httpd/CheckList.py:39: GtkDeprecationWarning: gtk.FALSE
is deprecated, use False instead
  self.set_row_data (row, (not not init_value, row_data))
/usr/share/system-config-httpd/ApacheConf.py:1072: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_column_auto_resize (0, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1073: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_column_auto_resize (1, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1074: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  vbox.pack_start (clist, TRUE, TRUE, 0)
/usr/share/system-config-httpd/ApacheConf.py:1075: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  hbox = gtk.HBox (FALSE, 4)
/usr/share/system-config-httpd/ApacheConf.py:1076: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  vbox.pack_start (hbox, FALSE, FALSE, 0)
/usr/share/system-config-httpd/ApacheConf.py:1085: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_column_auto_resize (0, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1086: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_column_auto_resize (1, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1087: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  vbox.pack_start (clist, TRUE, TRUE, 0)
/usr/share/system-config-httpd/ApacheConf.py:151: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  button1.set_sensitive (FALSE)
/usr/share/system-config-httpd/ApacheConf.py:152: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  button2.set_sensitive (FALSE)
/usr/share/system-config-httpd/ApacheConf.py:1091: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  xml.get_widget ("deny_list_frame").set_sensitive (FALSE)
/usr/share/system-config-httpd/ApacheConf.py:1092: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  xml.get_widget ("allow_list_frame").set_sensitive (FALSE)
/usr/share/system-config-httpd/ApacheConf.py:1096: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_reorderable (TRUE)
/usr/share/system-config-httpd/ApacheConf.py:123: DeprecationWarning: use
gtk.TreeView
  gtk.CList.__init__ (self, 3, [_("Error Code"), _("Behavior"), _("Location")])
/usr/share/system-config-httpd/ApacheConf.py:124: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  self.set_column_auto_resize (0, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:125: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  self.set_column_auto_resize (1, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:126: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  self.set_column_auto_resize (2, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1127: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  vbox.pack_start (clist, TRUE, TRUE, 0)
/usr/share/system-config-httpd/ApacheConf.py:1134: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_column_auto_resize (0, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1135: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_column_auto_resize (1, TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1143: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  clist.set_reorderable (TRUE)
/usr/share/system-config-httpd/ApacheConf.py:147: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  button1.set_sensitive (TRUE)
/usr/share/system-config-httpd/ApacheConf.py:148: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  button2.set_sensitive (TRUE)
/usr/share/system-config-httpd/ApacheConf.py:1247: GtkDeprecationWarning:
gtk.mainloop is deprecated, use gtk.main instead
  gtk.mainloop ()


Version-Release number of selected component (if applicable):

5:1.3.1-2

How reproducible:

always

Steps to Reproduce:
1. start program at console
2.
3.
  
Actual results:

extraneous warnings

Expected results:

no warnings

Additional info:

Most system-config-* have the same problems, I'm opening a bug for each.
Comment 1 Phil Knirsch 2005-05-04 10:25:02 EDT
Working on various fixes for s-c-h, so it might not make it into FC4, but a
newer version will appear sometime this or next month which fixes most if not
all of those warning as well as some other minor fixes.

Read ya, Phil
Comment 2 Phil Knirsch 2005-05-23 06:33:26 EDT
*** Bug 145569 has been marked as a duplicate of this bug. ***
Comment 3 Phil Knirsch 2005-05-23 08:34:38 EDT
Fixed in system-config-httpd-1.3.1-2 and later

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.