Bug 1530730 - [downstream clone - 4.2.1] [RFE] Allow uploading ISO images to data domains and using them in VMs
Summary: [downstream clone - 4.2.1] [RFE] Allow uploading ISO images to data domains a...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: All
OS: All
medium
medium
Target Milestone: ovirt-4.2.1
: ---
Assignee: Tal Nisan
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On: 1122970 1532537 1536826
Blocks: 1548856
TreeView+ depends on / blocked
 
Reported: 2018-01-03 16:58 UTC by rhev-integ
Modified: 2020-03-11 15:55 UTC (History)
39 users (show)

Fixed In Version: ovirt-engine-4.2.1.1
Doc Type: Enhancement
Doc Text:
The Manager and the REST API support uploading an ISO image to a data storage domain and attaching it to a virtual machine as a CDROM device.
Clone Of: 1122970
Environment:
Last Closed: 2018-02-26 09:28:59 UTC
oVirt Team: Storage
Target Upstream Version:
ebenahar: testing_plan_complete+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 normal SHIPPED_LIVE Red Hat Virtualization Manager (ovirt-engine) 4.2 GA 2018-06-07 17:27:12 UTC
oVirt gerrit 83136 master MERGED core: Allow uploading of ISO images through webadmin 2018-01-03 17:04:42 UTC
oVirt gerrit 84434 master MERGED core: Allow attach as CD of ISO images from data domain in webadmin 2018-01-03 17:04:42 UTC
oVirt gerrit 85018 master MERGED storage: Allow attaching a cdrom device from block domain 2018-01-03 17:04:42 UTC
oVirt gerrit 85019 master MERGED core: Allow attaching ISO file on data domains to VM as a cdrom 2018-01-03 17:04:42 UTC

Description rhev-integ 2018-01-03 16:58:56 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1122970 +++
======================================================================

+++ This bug was initially created as a clone of Bug #1091377 +++

Description of problem:
It would be helpful to be able to upload iso images through the gui.
Being able to add them through the hosted engine and through nfs is fine in many cases of course, but a more integrated solution into the webgui would be great.

Letting users choose their own iso seems a better solution in many cases, especially if it can go under their own resource pool.

First time poster, so please tell me if I'm doing anything incorrectly.

With my best regards
Klas

--- Additional comment from Sean Cohen on 2014-07-24 09:37:32 EDT ---

(Originally by Daniel Erez)

Comment 1 rhev-integ 2018-01-03 16:59:11 UTC
*** Bug 1093548 has been marked as a duplicate of this bug. ***

(Originally by Sean Cohen)

Comment 3 rhev-integ 2018-01-03 16:59:25 UTC
Created attachment 923963 [details]
mockup: Images sub-tab: action buttons

(Originally by ecohen)

Comment 4 rhev-integ 2018-01-03 16:59:38 UTC
Created attachment 923964 [details]
mockup: "Upload Image" dialog

(Originally by ecohen)

Comment 5 rhev-integ 2018-01-03 16:59:50 UTC
graphic design is pretty straight forward IMO:

- add "Upload", "Edit" (? maybe not needed) and "Remove" buttons to the "Images" sub-tab (displayed when an ISO domain is selected in the Storage main tab).
[see attachment 923963 [details]]

- Once "Upload" is clicked, the "Upload Image" dialog is opened. 
[see attachment 923964 [details]]

-  "Edit" opens an "Edit Image", which should be identical to the "Upload Image" dialog, with the information filled and potentially some of the fields disabled (again, probably doesn't make sense, hence not needed). 

- "Remove" should open a standard "are you sure" confirmation dialog.

(Originally by ecohen)

Comment 6 rhev-integ 2018-01-03 17:00:04 UTC
Moving to storage: it's a change needed in the engine webadmin for importing an image in an iso domain. Doesn't look like an integration task.

(Originally by Sandro Bonazzola)

Comment 7 rhev-integ 2018-01-03 17:00:18 UTC
*** Bug 706873 has been marked as a duplicate of this bug. ***

(Originally by Allon Mureinik)

Comment 8 rhev-integ 2018-01-03 17:00:29 UTC
*** Bug 630655 has been marked as a duplicate of this bug. ***

(Originally by Allon Mureinik)

Comment 9 rhev-integ 2018-01-03 17:00:42 UTC
Note to the UXD team:
We want to handle bug 706873 (uploading a VM's DISK, not an ISO) as part of this effort too.

This will probably require slightly different screens.

(Originally by Allon Mureinik)

Comment 10 rhev-integ 2018-01-03 17:00:56 UTC
Created attachment 1005575 [details]
mock-up: Import Disk

(Originally by ecohen)

Comment 11 rhev-integ 2018-01-03 17:01:09 UTC
(In reply to Allon Mureinik from comment #8)
> Note to the UXD team:
> We want to handle bug 706873 (uploading a VM's DISK, not an ISO) as part of
> this effort too.
> 
> This will probably require slightly different screens.

Thanks for the update, Allon. 

After discussing with Liz:

It may make sense to utilize the 'Import' terminology that we are using throughout the application to represent the action of adding a pre-defined item to the system, rather than creating a 'New' one from scratch. 

It would probably make sense to make this action available from the Disks sub-tab of the VMs main tab as well as from the Disks main-tab [see attachment 1005575 [details]]. 

I am not sure if we will have (or already have) capabilities of importing a Disk from e.g. an Export domain - if we do / will, it would make sense to enable this capability from the same button/dialog, and let the user the option to choose whether he wants to Import the Disk from his local file system, from an Export domain, etc. 

If makes completely no sense to use the 'Import' terminology here, I guess that we can use 'Upload' instead (similarly to the action-name for the ISOs - see attachment 923963 [details]). We can also change the terminology for ISOs to 'Import' (though in ISOs, we are never creating new ones from scratch anyway, so a bit of a different case here). 

If you need any further UXD assistance, please feel free to further 'needinfo' us. thanks.

(Originally by ecohen)

Comment 12 rhev-integ 2018-01-03 17:01:20 UTC
From the mockup images it appears as though the graphical image/iso uploader will only support NFS paths.  Will http and/or smb also be an option so users can specify a path like http://$host/$file.iso or smb://$user@$host/$file.iso?

It would be nice for users to be able to upload images/isos from their local machines.  Supporting smb and nfs may provide a way to allow this by allowing users to create a share or export on their local machine.

(Originally by tony)

Comment 13 rhev-integ 2018-01-03 17:01:32 UTC
Morning

I was today in a customer and we was testing and comparing environments (RHEV and VMWare) and this point was very important. In VMWare the client can upload/download image, all from webui, without necessity to copy .iso file between machines for example. This will be a great feature in RHEV, the idea is just upload to ISO data store, defining the correct permission, or download if necessary, without necessity to access the server via cli.

Appreciate and let me know if I can help you about it.

B'Regards
Waldirio

(Originally by Waldirio Pinheiro)

Comment 14 rhev-integ 2018-01-03 17:01:44 UTC
Good morning

Would like to ask if are there roadmap for this feature.

Appreciate
Waldirio

(Originally by Waldirio Pinheiro)

Comment 15 rhev-integ 2018-01-03 17:01:55 UTC
(In reply to Waldirio M Pinheiro from comment #13)
> Good morning
> 
> Would like to ask if are there roadmap for this feature.
> 
> Appreciate
> Waldirio

We are planning to add image uploader in the GUI on RHEV 4.0.
ISO uploader is planned later on and requires some infra work which has already started.

(Originally by ylavi)

Comment 20 rhev-integ 2018-01-03 17:02:46 UTC
*** Bug 1091377 has been marked as a duplicate of this bug. ***

(Originally by Daniel Erez)

Comment 22 rhev-integ 2018-01-03 17:03:09 UTC
No qe_ack:

No feature page available for us to test this feature

(Originally by Raz Tamir)

Comment 23 rhev-integ 2018-01-03 17:03:20 UTC
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

(Originally by pm-rhel)

Comment 24 rhev-integ 2018-01-03 17:03:34 UTC
(In reply to Raz Tamir from comment #21)
> No qe_ack:
> 
> No feature page available for us to test this feature

Please use QE Conditional NAK. Nacking means you are not willing to test and it closes the ticket.

(Originally by ylavi)

Comment 26 rhev-integ 2018-01-03 17:03:57 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

(Originally by rule-engine)

Comment 27 rhev-integ 2018-01-03 17:04:09 UTC
Please provide doc text first.

(Originally by ylavi)

Comment 28 rhev-integ 2018-01-03 17:04:20 UTC
In order to create an ISO disk container via the REST-API the following should be specified within the request:

<disk>
 ....
 <content_type>iso</content_type>
 ....
</disk>


When the disk exists on an active storage domain in the data center it can be attached to the VM as a CDROM device via the REST-API by sending a POST request to: ....ovirt-engine/api/vms/{vm-id}/cdroms

With the content:

<cdrom>
 <file id="{disk-id}"/>
</cdrom>

Where {disk-id} is the ID of the ISO disk created

(Originally by Tal Nisan)

Comment 29 RHV bug bot 2018-01-05 16:58:00 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{}', ]

For more info please contact: rhv-devops@redhat.com

Comment 30 Michal Skrivanek 2018-01-22 13:28:46 UTC
seems it's broken - see bug 1536826

Comment 31 Yaniv Lavi 2018-02-26 09:28:59 UTC
No need to track for 4.3.
Closing.

Comment 33 Franta Kust 2019-05-16 12:54:57 UTC
BZ<2>Jira re-sync


Note You need to log in before you can comment on or make changes to this bug.