Bug 153155 - timer interrupt received twice on ATI chipset motherboard, clock runs at double speed
timer interrupt received twice on ATI chipset motherboard, clock runs at doub...
Status: CLOSED DUPLICATE of bug 173236
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-04-01 16:12 EST by wingc
Modified: 2013-08-05 21:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-12 18:05:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
boot dmesg from latest RHEL4 kernel (2.6.9-5.0.3.EL) (12.98 KB, text/plain)
2005-04-01 16:15 EST, wingc
no flags Details
boot dmesg from latest RHEL4 kernel (2.6.9-5.0.3.EL), with APIC mode disabled in BIOS (12.75 KB, text/plain)
2005-04-02 13:40 EST, wingc
no flags Details

  None (edit)
Description wingc 2005-04-01 16:12:17 EST
This is the same problem as bug #152630:


The bug is still present in the latest RHEL4 update kernel (2.6.9-5.0.3.EL).

Note that my initial guess about the problem in RHEL3 must have been wrong. The
ACPI code in RHEL4 is more up to date, and includes all the patches to mpparse.c
which I was trying in the RHEL3 kernel.

Something else must be causing the timer interrupt to be received twice. The
workaround must have fixed things by using the XT-PIC to handle the timer
instead of the APIC.
Comment 1 wingc 2005-04-01 16:15:03 EST
Created attachment 112601 [details]
boot dmesg from latest RHEL4 kernel (2.6.9-5.0.3.EL)

this is the boot dmesg from the latest update kernel.
Comment 2 wingc 2005-04-01 16:19:06 EST
I also get the following error messages from the kernel, seemingly when the
system is under load. (network or disk controller)

APIC error on CPU0: 00(40)
APIC error on CPU0: 40(40)
Comment 3 wingc 2005-04-01 18:05:14 EST
Confirmed that this problem exists in the latest official 2.6 kernel (

I downloaded linux- from kernel.org and used the existing RHEL4
kernel source RPM to build the kernel. (I removed all the Red Hat %patches, and
used 'make config' to translate the existing Red Hat kernel configs into
something that would work with vanilla

My new kernel RPM built, installed, and booted fine. The clock still
runs at twice normal speed though.

$ uname -r

$ cat /proc/interrupts; sleep 10; cat /proc/interrupts
(5 seconds go by)

  0:    1215570    IO-APIC-edge  timer
LOC:     607691

  0:    1225584    IO-APIC-edge  timer
LOC:     612698

(2000 timer ints/second, 1000 local APIC ints/second)

I still get:

APIC error on CPU0: 00(40)
APIC error on CPU0: 40(40)

I may report this to the linux-kernel mailing list, and see if this is a Linux
bug or a bad BIOS.
Comment 4 wingc 2005-04-02 13:38:25 EST
The problem goes away when I disable APIC mode entirely (via a BIOS option).
This corresponds to my earlier experience with RHEL3 and the 2.4 kernel; the
patches I tried ended up somehow making only the timer interrupt handled via the
XT-PIC, but left the other interrupts going through the APIC.

A BIOS upgrade did not resolve the problem. (when APIC mode is enabled)

I entered a support request with the system manufacturer.
Comment 5 wingc 2005-04-02 13:40:01 EST
Created attachment 112625 [details]
boot dmesg from latest RHEL4 kernel (2.6.9-5.0.3.EL), with APIC mode disabled in BIOS

The clock works properly when APIC mode is disabled in the BIOS; all interrupts
in /proc/interrupts are labeled 'XT-PIC'.
Comment 6 Sybren 2005-08-11 03:28:09 EDT
I encountered this bug in FC4_x86-64 (kernel version 2.6.12-1.1398) on an Acer
Aspire 5024WLMi (AMD Turion64 ML-34 prcoessor, ATI Mobility Radeon XPRESS 200
series chipset). The output of cat /proc/interrupts is similar to that of
Comment #2 above.
However, the Phoenix BIOS (version 1.11) of this laptop does not offer the
opportunity to disable APIC mode as suggested above.
Is there any opportunity to correct my system clock?
Am I to post a new bug as this concerns FC4 (another "product")?
Comment 7 starlight 2005-12-05 12:56:27 EST
Also encountered this problem with a new Compaq Presario SR1030Z.
Also can't disable APIC mode in BIOS.  System clock situation
improves when booting with 'noapic' kernel parameter--but LAN
connectivity stops working.  Tried a few kernels with same result:


I need to get this machine in a useable state.  Will buying
a different video adapter and disabling the mainboard ATI
work around the problem?
Comment 8 starlight 2005-12-05 19:52:57 EST
FYI this is the same as FC4 bug 152170.
Much information there.
Comment 10 Jim Paradis 2006-09-12 18:05:33 EDT
This bug is the same issue as Bug 173236, which was fixed in RHEL4.4

*** This bug has been marked as a duplicate of 173236 ***

Note You need to log in before you can comment on or make changes to this bug.