Bug 153170 - sata_sil missing PCI IDs for ATI SATA controller
sata_sil missing PCI IDs for ATI SATA controller
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-01 17:48 EST by wingc
Modified: 2015-01-04 17:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-26 22:15:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wingc 2005-04-01 17:48:14 EST
This is a copy of bug #152627. The problem still exists in the latest RHEL4
errata kernel (2.6.9-5.0.3.EL)


The PCI IDs for the ATI IGP integrated SATA controller need to be added to
drivers/scsi/sata_sil.c and the boot loader image needs to be updated so the
installer recognizes this hardware.

The PCI IDs in question are:
0x1002  0x436e  "sata_sil"      "ATI|IXP300 SATA"
0x1002  0x4379  "sata_sil"      "ATI|IXP400 SATA"

The linux-2.6 changeset in question is:
http://linus.bkbits.net:8080/linux-2.5/cset@41e4b5df5jSP3VOlsSO6pnMqEBX79A


I confirmed that the RHEL4 kernel works properly once these PCI IDs are added to
drivers/scsi/sata_sil.c. I followed the same procedure as I described in bug
#152627; recompiling the driver and creating a driver update disk to use with
Anaconda. Everything worked properly.


Sorry, I couldn't see any channel for RHEL4 beta packages when I log into the
Red Hat network page. Otherwise I would have tried taking a look to see if this
has already been committed for future RHEL4 updates.
Comment 1 Jay Turner 2005-04-04 04:59:53 EDT
IDs confirmed in kernel-2.6.9-6.37.EL (U1-candidate kernel)

Note You need to log in before you can comment on or make changes to this bug.