Bug 153247 - eclipse-debuginfo is missing source code and debuginfo
eclipse-debuginfo is missing source code and debuginfo
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
bzcl34nup
:
: 217004 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-03 20:23 EDT by Robin Green
Modified: 2008-04-04 20:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 20:57:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
specfile patch (1.12 KB, patch)
2005-05-11 15:38 EDT, Robin Green
no flags Details | Diff

  None (edit)
Description Robin Green 2005-04-03 20:23:20 EDT
Description of problem:
The eclipse-debuginfo package is missing the source code.

Version-Release number of selected component (if applicable):
eclipse-debuginfo-3.1.0_fc-0.M5.15
Comment 1 Andrew Overholt 2005-05-01 12:48:09 EDT
Paul said he would comment on this when he had a chance.  The source for
debuginfo is apparently being lost in the .java -> .jar -> .jar.so compilations.
Comment 2 Robin Green 2005-05-09 20:16:48 EDT
I believe this is due to the absence of -g in the .jar -> .jar.so compilation.

I will test a .spec patch tommorow. Eclipse takes several hours to build on my
box - we'll see if adding $RPM_BUILD_OPTS to the gcj command line fixes it.
Comment 3 Robin Green 2005-05-09 20:20:15 EDT
By the way, not only does eclipse-debuginfo not contain any source code, it
appears to be missing a lot of debugging info. Updated summary.
Comment 4 Robin Green 2005-05-11 15:38:57 EDT
Created attachment 114257 [details]
specfile patch

The -g flag has already been added in CVS, which is half the problem solved.
The attached patch completes the fix. There are a lot of spurious cpio errors
when rpmbuild builds the -debuginfo package, which are due to
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=20735, but it works.

(A similar strategy should also work for ant, which also doesn't have any
source code in its debuginfo package.)
Comment 5 Andrew Overholt 2005-05-12 12:06:01 EDT
Thanks for the patch.  I agree with you that it's a hack :)

Paul, can you think of a better way to do this?  There are a few options:

1. change gdb to read from zipped sources (which are in eclipse*-devel already)
   (and set that up ie. path resolution)
2. change Eclipse to read source from debuginfo files (lame from and Eclipse 
standpoint)
3. ram the source into the debuginfo packages a la Robin's patch (duplicates the
code but if people install debuginfo I guess they know what they're getting into
...)

3. is probably the best option ATM, but it's very package-specific and we're
going to need to do it for all java packages in FC.

Are there other options we're missing?
Comment 6 Robin Green 2005-08-15 11:02:54 EDT
There is another problem now. The libswt debuginfo is not being included in the
debuginfo package.

I'd hazard a guess that's because libswt is in the wrong place. It should not be
under /usr/share because it's a native lib. Instead, it should be somewhere
under /usr/lib and symlinked from the location eclipse expects to find it at.
Comment 7 Andrew Overholt 2006-02-10 11:12:37 EST
(In reply to comment #6)
> I'd hazard a guess that's because libswt is in the wrong place. It should not be
> under /usr/share because it's a native lib. Instead, it should be somewhere
> under /usr/lib and symlinked from the location eclipse expects to find it at.

The JNI .sos for libswt are in /usr/lib and symlinked.
Comment 8 Ben Konrath 2007-02-06 15:11:57 EST
*** Bug 217004 has been marked as a duplicate of this bug. ***
Comment 9 Bug Zapper 2008-04-03 11:54:54 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 10 Andrew Overholt 2008-04-03 14:56:14 EDT
I don't have time to work on this and seeing as people haven't run into a
problem with this in a long time, it's probably safe to close.  We can always
re-open later.
Comment 11 John Poelstra 2008-04-04 20:57:50 EDT
thanks for your update

Note You need to log in before you can comment on or make changes to this bug.