Bug 1532969 - [RFE] Q35: Support booting virtual machines via UEFI
Summary: [RFE] Q35: Support booting virtual machines via UEFI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.8
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-4.3.0
: ---
Assignee: Shmuel Melamud
QA Contact: Nisim Simsolo
URL:
Whiteboard:
: 1539684 (view as bug list)
Depends On: oVirt_Q35_tech_preview_support 1327846 1365938 1613496
Blocks: 1509931
TreeView+ depends on / blocked
 
Reported: 2018-01-10 06:41 UTC by Germano Veit Michel
Modified: 2021-06-10 14:20 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, virtual machines could only boot from BIOS. The current release adds support for booting virtual machines via UEFI firmware, a free, newer, more modern way to initialize a system.
Clone Of: 1327846
Environment:
Last Closed: 2019-05-08 12:36:59 UTC
oVirt Team: Virt
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:37:22 UTC

Description Germano Veit Michel 2018-01-10 06:41:01 UTC
+++ This bug was initially created as a clone of Bug #1327846 +++

Description of problem:
Currently, oVirt only supports booting virtual machines via BIOS. However, UEFI is the newer, more modern way to initialize a system. Additionally, now that the licensing for the UEFI firmware is fully Free, a firmware package can be included to make this work.

Please add support for booting via UEFI in oVirt 4.0.0.

--- Additional comment from Michal Skrivanek on 2016-04-18 06:45:31 EDT ---

we will build UEFI (and secure boot) on top of q35 chipset, tracked in bug 1301111.
This would likely be TestOnly once it's implemented. Will keep open and revisit this bug once we get closer

--- Additional comment from Ludek Finstrle on 2017-07-13 03:35:38 EDT ---

Is there some progress. I see it as a blocker for my usecase.

--- Additional comment from Michal Skrivanek on 2017-07-20 10:22:16 EDT ---

(In reply to Ludek Finstrle from comment #3)
> Is there some progress. I see it as a blocker for my usecase.

Not much progress yet. There are more details in devel card https://trello.com/c/jIJRQw3z

Comment 1 Germano Veit Michel 2018-01-10 06:43:19 UTC
Was trying to write a hook to enable ovmf in order to test booting from a pci-e sas card via vfio (without firmare), hitting BZ1527740.

So this RFE is probably blocked by that BZ as well.

Comment 2 Michal Skrivanek 2018-08-22 11:29:20 UTC
feature page: https://www.ovirt.org/develop/release-management/features/virt/ovmf/

Comment 3 Michal Skrivanek 2018-11-26 15:46:00 UTC
*** Bug 1539684 has been marked as a duplicate of this bug. ***

Comment 5 Nisim Simsolo 2019-04-16 11:38:56 UTC
Verification version:
rhvm-4.3.3.3-0.1.el7
vdsm-4.30.13-1.el7ev.x86_64
libvirt-4.5.0-10.el7_6.7.x86_64
qemu-kvm-rhev-2.12.0-21.el7.x86_64
sanlock-3.6.0-1.el7.x86_64
virt-v2v-1.38.2-12.29.lp.el7ev.x86_64

Verification scenario:
Polarion test plan added to external trackers.

Comment 7 errata-xmlrpc 2019-05-08 12:36:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.