Bug 1301111 - (oVirt_Q35_tech_preview_support) [RFE] [tech preview] Support q35-based machine type in addition to i440fx
[RFE] [tech preview] Support q35-based machine type in addition to i440fx
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Martin Polednik
meital avital
: FutureFeature, TechPreview
Depends On: 1227278 1305900 1322248 1330988
Blocks: 1327846 1365938
  Show dependency treegraph
 
Reported: 2016-01-22 10:48 EST by Michal Skrivanek
Modified: 2017-05-27 22:54 EDT (History)
10 users (show)

See Also:
Fixed In Version: 4.0.0-12
Doc Type: Technology Preview
Doc Text:
This update provides support for the Q35-based machine type supported by QEMU, it is an alternative to older i440fx chipset. Compared to i440fx, Q35 allows for better support of PCI-e passthrough as it has a proper PCI-e bus[1]. One of the differences is also that the Q35 does not use IDE cdrom, but prefers SATA bus. The reason for that is the lack of IDE. [1] http://wiki.qemu.org/Features/Q35
Story Points: ---
Clone Of:
: 1365938 (view as bug list)
Environment:
Last Closed: 2016-08-23 16:32:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Skrivanek 2016-01-22 10:48:16 EST
support q35 chipset
Comment 1 Michal Skrivanek 2016-01-22 10:53:45 EST
need to get rid of floppy and resolve CDROM (for payload/cloud-init, sysprep, and regular use).
Alternatively we may want to use USB
Comment 4 Michal Skrivanek 2016-05-18 09:27:48 EDT
We have everything in place to call this a tech preview. With patch 56588 VMs one can configure VMs with q35 chipset and they will work with CDs as well. Basic functionality should work.
Floppy support is not ready, not important enough due to tech preview status. Workarounds exist and will be documented
Comment 7 Michal Skrivanek 2016-08-10 10:38:44 EDT
code is ready in 4.0 GA but not tested, testing tracked in child bug.
It needs to be documented as a tech preview
Comment 10 errata-xmlrpc 2016-08-23 16:32:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.