Bug 15346 - Problem with mount
Problem with mount
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 16585 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 22:54 EDT by mal
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 16:15:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the /var/log/messages with cdrom debug on (84.09 KB, text/plain)
2001-02-05 11:54 EST, mal
no flags Details

  None (edit)
Description mal 2000-08-03 22:54:39 EDT
There is a problem how gnome CD automounting 
(on desktop) interacts with the system.
When you try to mount a disk manually you get
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (aren't you trying to mount an extended partition,
       instead of some logical partition inside?)
because gnome desctop is trying to mount the CD.
It should be a more advanced algorithm to fix this kind of conflicts.
Comment 1 mal 2000-08-05 22:41:49 EDT
In addition:
I am not sure what causes this problem.
The CD was burned on HP9100i CDRW from RedHat 7.0 Beta ISO images.
When the described event happens in
 /var/log/messages I get
Aug  5 11:00:02 eth0_extrenal kernel: hdc: ATAPI 32X CD-ROM drive, 256kB Cache
Aug  5 11:20:02 eth0_extrenal kernel: hdc: ATAPI 32X CD-ROM drive, 256kB Cache
Aug  5 11:50:01 eth0_extrenal kernel: hdc: ATAPI 32X CD-ROM drive, 256kB Cache
Aug  5 12:22:01 eth0_extrenal kernel: attempt to access beyond end of device
Aug  5 12:22:01 eth0_extrenal kernel: 16:00: rw=0, want=33, limit=0
Aug  5 12:22:01 eth0_extrenal kernel: dev 16:00 blksize=1024 blocknr=32
sector=64 size=1024 count=1
Aug  5 12:22:01 eth0_extrenal kernel: isofs_read_super: bread failed, dev=16:00,
iso_blknum=16, block=32
Aug  5 12:22:01 eth0_extrenal kernel: attempt to access beyond end of device
Aug  5 12:22:01 eth0_extrenal kernel: 16:00: rw=0, want=33, limit=0
Aug  5 12:22:01 eth0_extrenal kernel: dev 16:00 blksize=1024 blocknr=32
sector=64 size=1024 count=1
Aug  5 12:22:01 eth0_extrenal kernel: isofs_read_super: bread failed, dev=16:00,
iso_blknum=16, block=32
Aug  5 12:22:03 eth0_extrenal kernel: attempt to access beyond end of device
Aug  5 12:22:03 eth0_extrenal kernel: 16:00: rw=0, want=33, limit=0
Aug  5 12:22:03 eth0_extrenal kernel: dev 16:00 blksize=1024 blocknr=32
sector=64 size=1024 count=1
Aug  5 12:22:03 eth0_extrenal kernel: isofs_read_super: bread failed, dev=16:00,
iso_blknum=16, block=32
Aug  5 12:22:09 eth0_extrenal kernel: attempt to access beyond end of device
Aug  5 12:22:09 eth0_extrenal kernel: 16:00: rw=0, want=33, limit=0
...............
Comment 2 Dale Lovelace 2000-08-19 14:36:01 EDT
This is a magicdev problem. Changing to magicdev.
Comment 3 Elliot Lee 2000-08-21 14:10:48 EDT
What happens when you try to mount a CD that you know works (instead of one you
burned yourself)?
Comment 4 mal 2000-08-21 14:28:31 EDT
This problem does hot happen too often,
so it is hard to trigger.
I can not trigger this problem right now 
neither with burned nor with factory-manufactured CDs.
Nothing changed since this problem first appear.
Comment 5 Elliot Lee 2000-08-21 14:38:54 EDT
*** Bug 16585 has been marked as a duplicate of this bug. ***
Comment 6 mal 2000-08-21 14:47:17 EDT
The problem can be triggered with factory-manufactured CD.
This is what I have when using RedHat 6.2 CD from the store.

mount /mnt/cdrom/
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (aren't you trying to mount an extended partition,
       instead of some logical partition inside?)
[root@eth0_extrenal /root]# 

tail /var/log/messages output:
Aug 21 14:24:18 eth0_extrenal PAM_unix[9238]: (system-auth) session opened for
user root by mal(uid=500)
Aug 21 14:48:55 eth0_extrenal kernel: attempt to access beyond end of device
Aug 21 14:48:55 eth0_extrenal kernel: 16:00: rw=0, want=33, limit=0
Aug 21 14:48:55 eth0_extrenal kernel: dev 16:00 blksize=1024 blocknr=32
sector=64 size=1024 count=1
Aug 21 14:48:55 eth0_extrenal kernel: isofs_read_super: bread failed, dev=16:00,
iso_blknum=16, block=32
Aug 21 14:48:55 eth0_extrenal kernel: attempt to access beyond end of device
Aug 21 14:48:55 eth0_extrenal kernel: 16:00: rw=0, want=33, limit=0
Aug 21 14:48:55 eth0_extrenal kernel: dev 16:00 blksize=1024 blocknr=32
sector=64 size=1024 count=1
Aug 21 14:48:55 eth0_extrenal kernel: isofs_read_super: bread failed, dev=16:00,
iso_blknum=16, block=32
Aug 21 14:50:02 eth0_extrenal kernel: hdc: ATAPI 32X CD-ROM drive, 256kB Cache
[root@eth0_extrenal /root]# tail -40 /var/log/messages

Then 5 minutes later I do 
mount /mnt/cdrom/
And it works. no errors in /var/log/messages after that.
Comment 7 mal 2000-08-21 14:53:36 EDT
Also, the same message is printed to linux console

mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (aren't you trying to mount an extended partition,
       instead of some logical partition inside?)

Is it possible this is a problem with kernel,
not with magicdev
Comment 8 Elliot Lee 2000-08-21 15:05:14 EDT
> Is it possible this is a problem with kernel,
> not with magicdev

It is my opinion that this is a kernel problem, but I have not conferred with
any kernel hackers yet, nor have I looked into the details of the bug. :(
Comment 9 mal 2000-08-22 11:31:12 EDT
The model I have 
cat /proc/ide/hdc/model
NEC CD-ROM DRIVE:28B

cat /proc/ide/hdc/driver 
ide-cdrom version 4.58
Comment 10 Need Real Name 2000-10-03 16:17:40 EDT
This seems to be a kernel problem.
The problem still exists in RedHat 7.0 release
Comment 11 Need Real Name 2000-11-24 11:47:42 EST
The problem seems to go away after
rmmod ide-cd
modprobe ide-cd
Comment 12 Need Real Name 2000-12-28 12:22:55 EST
The problem exists with 3 different types of CD-ROM drives.
Also, when useing ide-scsi for the CDROM and then 
mounting CDROM as a SCSI device everything is working OK.
Comment 13 Elliot Lee 2001-01-22 19:21:18 EST
Kernel gurus, attack.
Comment 14 mal 2001-02-05 11:54:03 EST
Created attachment 9022 [details]
This is the /var/log/messages with cdrom debug on
Comment 15 Alan Cox 2003-06-05 16:15:56 EDT
Modern Red Hat (and all Linux ) allows something to be mounted multiple times,
so the issue about desktop mounting is gone

Note You need to log in before you can comment on or make changes to this bug.