Bug 1535474 - Resharding hangs with versioning-enabled buckets
Summary: Resharding hangs with versioning-enabled buckets
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z3
: 3.0
Assignee: Orit Wasserman
QA Contact: ceph-qe-bugs
Aron Gunn
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1557269
TreeView+ depends on / blocked
 
Reported: 2018-01-17 13:22 UTC by Orit Wasserman
Modified: 2018-05-15 18:21 UTC (History)
13 users (show)

(edit)
.Manual and dynamic resharding no longer hangs on a bucket

Previously, when using the Ceph Object Gateway (RGW), doing manual and dynamic resharding would hang on a bucket that has versioning enabled.
Clone Of:
(edit)
Last Closed: 2018-05-15 18:20:29 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1563 None None None 2018-05-15 18:21 UTC
Ceph Project Bug Tracker 22721 None None None 2018-01-17 13:22 UTC

Description Orit Wasserman 2018-01-17 13:22:43 UTC
Description of problem:
The resharding process hangs on a versioning enabled bucket.
This effect dynamic resharding and manual resharding

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a bucket
2. Enable versioning on the bucket
3. Try to reshard the buckect using "radsogw-admin bucket reshard" command

Actual results:
resharding hangs

Expected results:
resharding succeeded

Additional info:

Comment 5 Orit Wasserman 2018-04-25 07:05:35 UTC
upstream fix:
https://github.com/ceph/ceph/pull/21584

Comment 12 errata-xmlrpc 2018-05-15 18:20:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1563


Note You need to log in before you can comment on or make changes to this bug.