Bug 1535614 - openstack overcloud container image prepare outputs empty list when sahara or cinder-backup referenced
Summary: openstack overcloud container image prepare outputs empty list when sahara or...
Keywords:
Status: CLOSED DUPLICATE of bug 1535971
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-containers
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Dan Prince
QA Contact: Omri Hochman
Andrew Burden
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-17 18:11 UTC by Pavel Sedlák
Modified: 2018-02-15 10:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-15 10:47:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1749468 None None None 2018-02-14 14:30:03 UTC
OpenStack gerrit 544357 None ABANDONED Autoeval container images for legacy services 2020-10-08 10:52:42 UTC
Red Hat Bugzilla 1535971 urgent CLOSED call to openstack overcloud containers image prepare returns almost empty list of containers 2020-10-14 00:28:05 UTC

Internal Links: 1535971

Description Pavel Sedlák 2018-01-17 18:11:30 UTC
When executing
> openstack overcloud container image prepare --namespace docker-registry.engineering.redhat.com/rhosp13 \
> --tag 2018-01-12.2 --prefix openstack- \
> --set ceph_namespace=registry.access.redhat.com/rhceph \
> --set ceph_image=rhceph-3-rhel7 --set ceph_tag=3-2 \
> --output-images-file /home/stack/container_images.yaml \
> --environment-file /usr/share/openstack-tripleo-heat-templates/environments/services/sahara.yaml \
> --environment-file /usr/share/openstack-tripleo-heat-templates/environments/cinder-backup.yaml

It generates empty list of images:
> container_images: []

Same command when used before for Pike/12 worked.

To generate non empty list, both sahara.yaml and cinder-backup.yaml had to be removed, just one of them still results in empty list.
List obtained after removing both can be see e.g. in other bugs attachment https://bugzilla.redhat.com/attachment.cgi?id=1382579 .

cat /usr/share/openstack-tripleo-heat-templates/environments/services/sahara.yaml
> resource_registry:
>   OS::TripleO::Services::SaharaApi: ../../puppet/services/sahara-api.yaml
>   OS::TripleO::Services::SaharaEngine: ../../puppet/services/sahara-engine.yaml

cat /usr/share/openstack-tripleo-heat-templates/environments/cinder-backup.yaml
> resource_registry:
>   OS::TripleO::Services::CinderBackup: ../puppet/services/pacemaker/cinder-backup.yaml
>   # For non-pcmk managed implementation
>   # OS::TripleO::Services::CinderBackup: ../puppet/services/cinder-backup.yaml(undercloud)

Comment 2 Bogdan Dobrelya 2018-02-13 10:56:56 UTC
I can reproduce it on my dev box with the client and t-h-t installed/clonned from master branches, via pip/git.

Comment 3 Bogdan Dobrelya 2018-02-13 11:01:30 UTC
It works though when --environment-files picked like from the services-docker/sahara.yaml and services-docker/cinder-backup.yaml (note: services-docker is used instead of just services)

Shall we change this to a docs bug perhaps?

Comment 7 Martin André 2018-02-15 10:47:11 UTC

*** This bug has been marked as a duplicate of bug 1535971 ***


Note You need to log in before you can comment on or make changes to this bug.