Bug 1535971 - call to openstack overcloud containers image prepare returns almost empty list of containers
Summary: call to openstack overcloud containers image prepare returns almost empty lis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Dan Prince
QA Contact: Omri Hochman
Andrew Burden
URL:
Whiteboard:
: 1535614 (view as bug list)
Depends On:
Blocks: 1581756
TreeView+ depends on / blocked
 
Reported: 2018-01-18 11:13 UTC by Jon Schlueter
Modified: 2018-08-03 18:35 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-common-8.3.1-0.20180103233643.el7ost python-tripleoclient-8.1.1-0.20171231084755.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1581756 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:42:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1535614 'urgent' 'CLOSED' 'openstack overcloud container image prepare outputs empty list when sahara or cinder-backup referenced' 2019-11-11 08:30:45 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:43:13 UTC

Internal Links: 1535614

Description Jon Schlueter 2018-01-18 11:13:01 UTC
Description of problem:

Using InfraRed we had case that was working for OSP 12 now failing for OSP 13

call to

openstack overcloud container image prepare 


is only returning the ceph container image



Version-Release number of selected component (if applicable):

puddle 2018-01-17.2

openstack-tripleo-common-8.3.1-0.20180103233642.el7ost
python-tripleoclient-8.1.1-0.20171231084754.52b71ea.el7ost


How reproducible:
Always

Steps to Reproduce:
1. CI job is reproducing issue
2.
3.

Actual results:

only ceph container image is in generated file

Expected results:

all of the normal container images are in the generated file for a successful deployment


Additional info:

Comment 10 Artem Hrechanychenko 2018-02-05 10:45:00 UTC
VERIFIED
openstack-tripleo-common-8.3.1-0.20180123050218.el7ost.noarch
python-tripleoclient-9.0.1-0.20180119233147.el7ost.noarch

(undercloud) [stack@undercloud-0 ~]$ openstack overcloud container image prepare --namespace=192.168.24.1:8787/rhosp13 --env-file=/home/stack/virt/docker-images.yaml  -e /usr/share/openstack-tripleo-heat-templates/environments/services/sahara.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/cinder-backup.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /home/stack/virt/internal.yaml -e /home/stack/virt/network/network-environment.yaml -e /home/stack/virt/hostnames.yml -e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml -e /home/stack/virt/debug.yaml -e /home/stack/virt/nodes_data.yaml  --prefix=openstack- --tag=2018-01-17.2 --set ceph_namespace=registry.access.redhat.com/rhceph --set ceph_image=rhceph-3-rhel7 --set ceph_tag=3-2
container_images:
- imagename: 192.168.24.1:8787/rhosp13/openstack-aodh-api:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-aodh-evaluator:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-aodh-listener:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-aodh-notifier:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-ceilometer-central:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-ceilometer-compute:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-ceilometer-notification:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-cinder-api:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-cinder-backup:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-cinder-scheduler:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-cinder-volume:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-cron:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-glance-api:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-gnocchi-api:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-gnocchi-metricd:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-gnocchi-statsd:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-haproxy:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-heat-api-cfn:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-heat-api:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-heat-engine:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-horizon:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-iscsid:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-keystone:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-mariadb:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-memcached:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-neutron-dhcp-agent:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-neutron-l3-agent:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-neutron-metadata-agent:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-neutron-openvswitch-agent:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-neutron-server:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-nova-api:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-nova-compute:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-nova-conductor:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-nova-consoleauth:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-nova-libvirt:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-nova-novncproxy:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-nova-placement-api:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-nova-scheduler:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-panko-api:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-rabbitmq:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-redis:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-sahara-api:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-sahara-engine:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-swift-account:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-swift-container:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-swift-object:2018-01-17.2
- imagename: 192.168.24.1:8787/rhosp13/openstack-swift-proxy-server:2018-01-17.2
- imagename: registry.access.redhat.com/rhceph/rhceph-3-rhel7:3-2

Comment 11 Martin André 2018-02-15 10:47:11 UTC
*** Bug 1535614 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2018-06-27 13:42:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.