Bug 1537054 - FFU: undercloud backup/restore procedure during FFU upgrade
Summary: FFU: undercloud backup/restore procedure during FFU upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z2
: 13.0 (Queens)
Assignee: Carlos Camacho
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks: 1561169
TreeView+ depends on / blocked
 
Reported: 2018-01-22 11:00 UTC by Marius Cornea
Modified: 2018-12-24 11:40 UTC (History)
16 users (show)

Fixed In Version: python-tripleoclient-9.2.0-4.el7ost openstack-tripleo-common-8.6.1-0.20180410165748.4d8ca16.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 16:34:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 466213 None MERGED Add Openstack Undercloud backup 2020-02-27 09:22:25 UTC
OpenStack gerrit 517610 None MERGED Add UC Backup Mistral workflow definition and actions 2020-02-27 09:22:25 UTC
OpenStack gerrit 549892 None MERGED Add Fast Forward Upgrade docs 2020-02-27 09:22:26 UTC
OpenStack gerrit 550380 None MERGED Add Openstack Undercloud backup 2020-02-27 09:22:25 UTC
Red Hat Product Errata RHBA-2018:2574 None None None 2018-08-29 16:35:49 UTC

Description Marius Cornea 2018-01-22 11:00:22 UTC
Description of problem:

In case anything goes horribly wrong during an FFU upgrade we should provide a method to rollback to the initial state in which the environment was before starting the upgrade. This ticket was filed to keep track of:

- undercloud backup before FFU
- overcloud backup before FFU
- undercloud restore from backup during failed FFU
- overcloud restore from backup during failed FFU

Comment 3 mathieu bultel 2018-04-11 10:52:25 UTC
Hi Maria, can you set your ack.
Thank you.

Comment 6 mathieu bultel 2018-04-18 06:50:26 UTC
Hi Carlos,

Im moving this RFE to POST since all the review attached is merged.
I let you change the status and comment the reason if needed.

Comment 8 Carlos Camacho 2018-04-18 08:49:20 UTC
Hi,

Yeah, all the reviews are merged. If we get further issues we will create additional BZs

Comment 9 Jon Schlueter 2018-04-18 15:15:50 UTC
https://review.openstack.org/#/c/466213/ is not on stable/queens and not yet proposed stable/queens for tripleoclient

Moving back to ASSIGNED to get action on it.

Comment 10 mathieu bultel 2018-04-18 15:17:31 UTC
The patch for stable/queens is here && merged:
https://review.openstack.org/#/c/550380/

Comment 15 Carlos Camacho 2018-05-18 11:40:35 UTC
Given this is part of the MVP and it will not run on production, we can remove the blocker flag.

Comment 16 Mike Orazi 2018-05-22 16:54:56 UTC
Carlos, I'm confused by https://bugzilla.redhat.com/show_bug.cgi?id=1537054#c15.  Can you clarify when this would be run or how we are advocating backup/restore would happen in prod?

Comment 19 Carlos Camacho 2018-08-06 10:36:39 UTC
The UC backup and restore works now also for FFU.


DFG:Metmon will handle the Overcloud backup and restore.

Comment 21 Joanne O'Flynn 2018-08-15 08:05:01 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 22 Marius Cornea 2018-08-20 09:25:55 UTC
Carlos,

I think there's some confusion around this BZ and the fixes attached to it so I'd like to clarify, some questions below:

1/ The initial report included both the undercloud and overcloud backup/restore requirement. If I understand it correctly you want to keep track only of the undercloud backup/restore procedure in this bug so if the overcloud backup/restore process should be tracked in a different bug then can we open a new one to keep track of it?

2/ undercloud backup and restore: in case of FFU the undercloud backup should be done before starting the upgrade procedure(when the deployment is still on OSP10). The patches attached to this bug were added to OSP13 so they can only work after the undercloud has been upgraded to 13. Do you plan to backport them to OSP10 to allow the backup to happen before starting the upgrade process?

Comment 23 Carlos Camacho 2018-08-22 07:05:09 UTC
Hi Marius,

Yes,

1/ This BZ is only for tracking the UC backup/restore, we should create another one for the Overcloud steps when they are implemented/tested.

2/ For the fixes we had a few regressions which were tested in >OSP13 for the CLI implementation, and for OSP10 we should follow the manual steps from [1], the regression we had was basically the xattr issue when creating the backup tarball.



[1]: https://docs.openstack.org/tripleo-docs/latest/install/controlplane_backup_restore/01_undercloud_backup.html

Comment 24 Marius Cornea 2018-08-22 07:29:05 UTC
OK then, I am changing the title to match the expectations. 

The undercloud backup/restore procedure during FFU(before upgrade) is manual and documented here: 

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/13/html-single/fast_forward_upgrades/#backing_up_the_undercloud

Comment 26 errata-xmlrpc 2018-08-29 16:34:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2574


Note You need to log in before you can comment on or make changes to this bug.