Bug 1537529 - gnome-system-log cant open display on Wayland [NEEDINFO]
Summary: gnome-system-log cant open display on Wayland
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 7.8
Assignee: Florian Müllner
QA Contact: Desktop QE
Jana Heves
URL:
Whiteboard:
Depends On:
Blocks: 1738389
TreeView+ depends on / blocked
 
Reported: 2018-01-23 12:55 UTC by Tomas Pelka
Modified: 2020-07-13 20:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
*gnome-system-log* does not work on *Wayland* Currently, when logged in a *Wayland* session, the root user is not allowed to access the user's Xwayland display. As a consequence, running the *gnome-system-log* utility in terminal does not display system log files. To work around this problem, run the following *xhost* server access control program as follows: $ xhost +si:localuser:root
Clone Of:
Environment:
Last Closed: 2020-07-13 20:01:48 UTC
Target Upstream Version:
jsvarova: needinfo? (rstrode)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 789867 0 Normal RESOLVED XAUTHORITY not configured for Xwayland 2020-07-13 20:01:23 UTC

Description Tomas Pelka 2018-01-23 12:55:17 UTC
Description of problem:
gnome-system-log is broken on wayland

Version-Release number of selected component (if applicable):
gnome-system-log-3.9.90-3.el7
xorg-x11-server-Xwayland-1.19.5-2.el7
libwayland-*-1.14.0-2.el7

How reproducible:
100%

Steps to Reproduce:
1. be logged into wayland session
2. open terminal
3. run gnome-system-log

Actual results:
No protocol specified

(logview:11210): Gtk-WARNING **: cannot open display: :1

Expected results:


Additional info:

Comment 1 Ray Strode [halfline] 2018-02-13 19:37:11 UTC
that's because we don't allow root to access the user's Xwayland display. 
running:

$ xhost +si:localuser:root

would probably fix it. 

mutter could presumably fix it with an XAddHost call.  Probably going to miss 7.5 at this point.


Note You need to log in before you can comment on or make changes to this bug.