Bug 1539830 - Suppress unlogged batch warnings in Cassandra logs
Summary: Suppress unlogged batch warnings in Cassandra logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.7.z
Assignee: Ruben Vargas Palma
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1548486 1548488
TreeView+ depends on / blocked
 
Reported: 2018-01-29 17:10 UTC by John Sanda
Modified: 2018-04-05 09:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1548486 1548488 (view as bug list)
Environment:
Last Closed: 2018-04-05 09:36:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:36:45 UTC

Description John Sanda 2018-01-29 17:10:52 UTC
Description of problem:
In OCP 3.7 changes were made in hawkular-metrics that result in lots of messages filling up Cassandra logs like this:

WARN  [SharedPool-Worker-13] 2018-01-17 18:02:36,963 NoSpamLogger.java:94 - Unlogged batch covering 12 partitions detected against table [hawkular_metrics.data_temp_2018011716]. You should use a logged batch for atomicity, or asynchronous writes for performance.

We have intentionally introduced the use of unlogged batches across multiple partitions within a single C* instance. I am seeing so many instances of these log statements some times that it makes debugging a C* pod difficult.

There is a property in cassandra.yaml, unlogged_batch_across_partitions_warn_threshold, that defaults to 10. I think we should set this property to 20 or 25. Doing so will eliminate most if not all of the warning messages.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Junqi Zhao 2018-02-23 06:12:48 UTC
Tested with Dockerfile-openshift3-metrics-cassandra-v3.7.33-1,
unlogged_batch_across_partitions_warn_threshold is set to 30 now, sanity testing is passed.

Set it to VERIFIED.

Comment 9 errata-xmlrpc 2018-04-05 09:36:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.