Bug 1539842 (glusterfs-4.0.0) - GlusterFS 4.0.0 tracker
Summary: GlusterFS 4.0.0 tracker
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: glusterfs-4.0.0
Product: GlusterFS
Classification: Community
Component: core
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1540660 1545724 1547635 1550392 1550894 1551112 1554018
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-29 17:44 UTC by Shyamsundar
Modified: 2018-03-15 11:26 UTC (History)
2 users (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-15 11:26:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2018-01-29 17:44:32 UTC
Tracker for the release 4.0.0

Comment 1 Worker Ant 2018-01-29 21:46:55 UTC
REVIEW: https://review.gluster.org/19370 (doc: Initial draft of 4.0.0 release notes) posted (#1) for review on release-4.0 by Shyamsundar Ranganathan

Comment 2 Worker Ant 2018-01-29 22:01:01 UTC
COMMIT: https://review.gluster.org/19370 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Initial draft of 4.0.0 release notes

This is an initial draft, that should render right in
github.

Need inputs from contributors to complete the notes.

Change-Id: I0e6a4f88b44ff46685e66f139758a2247954639d
BUG: 1539842
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 3 Worker Ant 2018-01-30 19:56:36 UTC
REVIEW: https://review.gluster.org/19389 (core: remove experimental xlators and associated tests) posted (#1) for review on release-4.0 by Shyamsundar Ranganathan

Comment 4 Worker Ant 2018-01-31 17:51:15 UTC
COMMIT: https://review.gluster.org/19389 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- core: remove experimental xlators and associated tests

experimental xlators removed from 4.0

> Cherry picked from 4231c40973c60999f5ef759db450d25e129ef6ba:
> Reviewed-on: https://review.gluster.org/17953
> Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>

Signed-off-by: ShyamsundarR <srangana@redhat.com>
Change-Id: I34419ce22ca09b7626b8f9382c377a614fd9fed8
BUG: 1539842

Comment 5 Worker Ant 2018-02-09 09:26:53 UTC
REVIEW: https://review.gluster.org/19535 (Release notes for #368) posted (#1) for review on release-4.0 by Pranith Kumar Karampuri

Comment 6 Worker Ant 2018-02-11 14:34:44 UTC
COMMIT: https://review.gluster.org/19535 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- Release notes for #368

BUG: 1539842
Change-Id: I9d4106f478e7244146998752ddf4f280225d339b
Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>

Comment 7 Worker Ant 2018-02-21 17:12:18 UTC
REVIEW: https://review.gluster.org/19610 (doc/release-notes: add information on FIPS compliance) posted (#1) for review on release-4.0 by Ravishankar N

Comment 8 Worker Ant 2018-02-22 07:59:21 UTC
REVIEW: https://review.gluster.org/19615 (Release notes for bug 1502610) posted (#1) for review on release-4.0 by Xavi Hernandez

Comment 9 Worker Ant 2018-02-23 16:45:58 UTC
COMMIT: https://review.gluster.org/19615 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- Release notes for bug 1502610

Change-Id: I6f983cea5f365795eb1ea205aad3edac04efa9c9
BUG: 1539842
Signed-off-by: Xavi Hernandez <jahernan@redhat.com>

Comment 10 Worker Ant 2018-02-23 16:47:27 UTC
COMMIT: https://review.gluster.org/19610 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc/release-notes: add information on FIPS compliance

Change-Id: Ib3d012c2b2a4a9281b9adb126a7d466086cc23f2
BUG: 1539842
Signed-off-by: Ravishankar N <ravishankar@redhat.com>

Comment 11 Worker Ant 2018-02-26 02:15:00 UTC
REVIEW: https://review.gluster.org/19624 (doc: Updated release notes for features lacking the same) posted (#1) for review on release-4.0 by Shyamsundar Ranganathan

Comment 12 Worker Ant 2018-02-26 02:39:46 UTC
COMMIT: https://review.gluster.org/19624 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Updated release notes for features lacking the same

Change-Id: I95a31107d879e089a2477bca9eb543da7880de8d
BUG: 1539842
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 13 Worker Ant 2018-02-26 06:20:11 UTC
REVIEW: https://review.gluster.org/19626 (doc: Update 4.0.0 release notes for GD2) posted (#1) for review on release-4.0 by Kaushal M

Comment 14 Worker Ant 2018-02-26 09:57:50 UTC
REVIEW: https://review.gluster.org/19631 (doc: Update geo-rep release notes) posted (#1) for review on release-4.0 by Kotresh HR

Comment 15 Worker Ant 2018-02-26 10:29:15 UTC
REVIEW: https://review.gluster.org/19632 (Release notes for atomic operations) posted (#1) for review on release-4.0 by Xavi Hernandez

Comment 16 Worker Ant 2018-02-26 18:39:12 UTC
COMMIT: https://review.gluster.org/19626 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Update 4.0.0 release notes for GD2

Change-Id: I8dce82bb3b7a1d48da2ad9a55bfa614b93e078ca
BUG: 1539842
Signed-off-by: Kaushal M <kaushal@redhat.com>

Comment 17 Worker Ant 2018-02-28 04:57:27 UTC
REVIEW: https://review.gluster.org/19645 (doc/release-notes: update some more components in perf section) posted (#1) for review on release-4.0 by Raghavendra G

Comment 18 Worker Ant 2018-02-28 07:35:26 UTC
REVIEW: https://review.gluster.org/19606 (doc/release-notes: Update about cluster.force-migration option) posted (#2) for review on release-4.0 by Raghavendra G

Comment 19 Worker Ant 2018-03-05 23:08:07 UTC
REVIEW: https://review.gluster.org/19676 (doc: Updated 4.0.0 release notes) posted (#1) for review on release-4.0 by Shyamsundar Ranganathan

Comment 20 Worker Ant 2018-03-05 23:41:07 UTC
COMMIT: https://review.gluster.org/19676 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Updated 4.0.0 release notes

Updated with content provided by others and during reviews

Change-Id: Id555ccc9571b6bbc87099def1e134a4171fb0439
BUG: 1539842
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 21 Worker Ant 2018-03-06 15:04:00 UTC
REVIEW: https://review.gluster.org/19681 (doc: Final edit of the release notes for 4.0.0) posted (#1) for review on release-4.0 by Shyamsundar Ranganathan

Comment 22 Worker Ant 2018-03-06 15:12:44 UTC
COMMIT: https://review.gluster.org/19681 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Final edit of the release notes for 4.0.0

Change-Id: I5bb23a616819d1f9774e02bf0982091daa5e3e68
BUG: 1539842
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 23 Worker Ant 2018-03-12 00:47:40 UTC
REVIEW: https://review.gluster.org/19697 (doc: Update release notes with bug fixed for upgrades) posted (#1) for review on release-4.0 by Shyamsundar Ranganathan

Comment 24 Worker Ant 2018-03-12 00:56:01 UTC
COMMIT: https://review.gluster.org/19697 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Update release notes with bug fixed for upgrades

Change-Id: Ia1df8e404aa53991a15fa46499a77dc16ef97677
BUG: 1539842
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 25 Shyamsundar 2018-03-15 11:26:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.