Bug 1547635 - add option to build rpm without server
Summary: add option to build rpm without server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Shyamsundar
QA Contact:
URL:
Whiteboard:
Depends On: 1074947
Blocks: glusterfs-4.0.0
TreeView+ depends on / blocked
 
Reported: 2018-02-21 16:21 UTC by Shyamsundar
Modified: 2018-03-15 11:27 UTC (History)
4 users (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1074947
Environment:
Last Closed: 2018-03-15 11:27:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2018-02-21 16:21:12 UTC
+++ This bug was initially created as a clone of Bug #1074947 +++

Currently there is no option to build without server ie client only builds.  We would need to fix it.

--- Additional comment from Worker Ant on 2018-02-19 12:39:24 EST ---

COMMIT: https://review.gluster.org/19419 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- build: add --without-server option

With Gluster 4.0 we will not provide the server components for EL6 and
older. At one point Gluster 4.x will get GlusterD2, which requires
Golang tools in the distribution. EL6 does not contain these at the
moment.

With this change, it is possible to `./configure --without-server` which
prevents building glusterd and the xlators for the bricks. Building RPMs
can pass `--without server` and the glusterfs-server sub-package will
not be created.

Change-Id: I97f5ccf9f2c76e60d9af83915fc59fae57ad6d25
BUG: 1074947
Signed-off-by: Niels de Vos <ndevos@redhat.com>

Comment 1 Worker Ant 2018-02-21 18:08:44 UTC
REVIEW: https://review.gluster.org/19612 (build: add --without-server option) posted (#1) for review on release-4.0 by Shyamsundar Ranganathan

Comment 2 Worker Ant 2018-02-22 21:02:06 UTC
COMMIT: https://review.gluster.org/19612 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- build: add --without-server option

With Gluster 4.0 we will not provide the server components for EL6 and
older. At one point Gluster 4.x will get GlusterD2, which requires
Golang tools in the distribution. EL6 does not contain these at the
moment.

With this change, it is possible to `./configure --without-server` which
prevents building glusterd and the xlators for the bricks. Building RPMs
can pass `--without server` and the glusterfs-server sub-package will
not be created.

Change-Id: I97f5ccf9f2c76e60d9af83915fc59fae57ad6d25
BUG: 1547635
Signed-off-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Shyamsundar 2018-03-15 11:27:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.