Bug 1541330 - [abrt] audacity: OnExit(): audacity killed by SIGABRT
Summary: [abrt] audacity: OnExit(): audacity killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacity
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Timms
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:70e3b1ea62cd6769b9a7a524494...
: 1551301 1552012 1644435 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-02 10:01 UTC by alain.thiaville
Modified: 2018-11-02 19:51 UTC (History)
9 users (show)

Fixed In Version: audacity-2.3.0-1.fc29 audacity-2.3.0-1.fc27 audacity-2.3.0-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 17:18:46 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (50.95 KB, text/plain)
2018-02-02 10:01 UTC, alain.thiaville
no flags Details
File: cgroup (195 bytes, text/plain)
2018-02-02 10:01 UTC, alain.thiaville
no flags Details
File: core_backtrace (27.26 KB, text/plain)
2018-02-02 10:01 UTC, alain.thiaville
no flags Details
File: cpuinfo (1.55 KB, text/plain)
2018-02-02 10:01 UTC, alain.thiaville
no flags Details
File: dso_list (11.71 KB, text/plain)
2018-02-02 10:01 UTC, alain.thiaville
no flags Details
File: environ (3.77 KB, text/plain)
2018-02-02 10:01 UTC, alain.thiaville
no flags Details
File: limits (1.29 KB, text/plain)
2018-02-02 10:02 UTC, alain.thiaville
no flags Details
File: maps (53.92 KB, text/plain)
2018-02-02 10:02 UTC, alain.thiaville
no flags Details
File: mountinfo (3.09 KB, text/plain)
2018-02-02 10:02 UTC, alain.thiaville
no flags Details
File: open_fds (1.00 KB, text/plain)
2018-02-02 10:02 UTC, alain.thiaville
no flags Details
File: proc_pid_status (1.27 KB, text/plain)
2018-02-02 10:02 UTC, alain.thiaville
no flags Details

Description alain.thiaville 2018-02-02 10:01:42 UTC
Description of problem:
recording while playing (backend pulseaudio)

Version-Release number of selected component:
audacity-2.1.3-5.fc27

Additional info:
reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        audacity
crash_function: OnExit
executable:     /usr/bin/audacity
journald_cursor: s=5bab3b6742a84986a8d797ba1c565f84;i=f4aa;b=d611179bf40740aaa10bd77ce97b7ecd;m=f870f3bc1;t=564379b27eb24;x=8ca6e5fc0be293ba
kernel:         4.14.13-300.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1001

Potential duplicate: bug 1529190

Comment 1 alain.thiaville 2018-02-02 10:01:49 UTC
Created attachment 1390038 [details]
File: backtrace

Comment 2 alain.thiaville 2018-02-02 10:01:50 UTC
Created attachment 1390039 [details]
File: cgroup

Comment 3 alain.thiaville 2018-02-02 10:01:53 UTC
Created attachment 1390040 [details]
File: core_backtrace

Comment 4 alain.thiaville 2018-02-02 10:01:54 UTC
Created attachment 1390041 [details]
File: cpuinfo

Comment 5 alain.thiaville 2018-02-02 10:01:56 UTC
Created attachment 1390042 [details]
File: dso_list

Comment 6 alain.thiaville 2018-02-02 10:01:58 UTC
Created attachment 1390043 [details]
File: environ

Comment 7 alain.thiaville 2018-02-02 10:02:00 UTC
Created attachment 1390044 [details]
File: limits

Comment 8 alain.thiaville 2018-02-02 10:02:02 UTC
Created attachment 1390045 [details]
File: maps

Comment 9 alain.thiaville 2018-02-02 10:02:04 UTC
Created attachment 1390046 [details]
File: mountinfo

Comment 10 alain.thiaville 2018-02-02 10:02:06 UTC
Created attachment 1390047 [details]
File: open_fds

Comment 11 alain.thiaville 2018-02-02 10:02:08 UTC
Created attachment 1390048 [details]
File: proc_pid_status

Comment 12 Clemens Eisserer 2018-02-26 10:46:51 UTC
Similar problem has been detected:

clicked on "record" after I had stopped recording a few moments ago, while audacity suddenly crashed.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        audacity
crash_function: OnExit
executable:     /usr/bin/audacity
journald_cursor: s=e5f649b5941f438298f85a602100c562;i=3271a;b=3c398ee656a840e1a2a9beeaa7913091;m=bdbaedb1;t=5661a9323cffc;x=b2c9ab2090bf1578
kernel:         4.15.4-300.fc27.x86_64
package:        audacity-2.1.3-5.fc27
reason:         audacity killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 Stepan Broz 2018-03-04 15:42:49 UTC
*** Bug 1551301 has been marked as a duplicate of this bug. ***

Comment 14 Andrew Martin 2018-03-06 10:32:56 UTC
*** Bug 1552012 has been marked as a duplicate of this bug. ***

Comment 15 Clemens Eisserer 2018-03-19 10:16:40 UTC
Similar problem has been detected:

started + stopped recording two times

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        audacity
crash_function: OnExit
executable:     /usr/bin/audacity
journald_cursor: s=38b0e1a2abd04b52bb35288575de1355;i=24906;b=d7a14c7a639d46ef95574e0fac1356e9;m=ebf42b50;t=567c123a3f983;x=c1d41130df587846
kernel:         4.15.9-300.fc27.x86_64
package:        audacity-2.1.3-5.fc27
reason:         audacity killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 16 Clemens Eisserer 2018-04-10 07:43:27 UTC
Similar problem has been detected:

pressed start/stop recording a few times with the internal mic selected

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        audacity
crash_function: OnExit
executable:     /usr/bin/audacity
journald_cursor: s=99e7f99b856f45adb12bb8879f52956a;i=aa2c;b=686b6f76046249599c5baf1ed09cf9c2;m=14b369284;t=5697990b0f1fb;x=ec15b71280973c4f
kernel:         4.15.14-300.fc27.x86_64
package:        audacity-2.1.3-5.fc27
reason:         audacity killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 17 David Timms 2018-04-28 02:52:40 UTC
I haven't been able ro reproduce this issue.

To Alain or Clemens:
Are you able to reproduce the error on demand ?
What is Preferences: Recording Plathrough: [ ]Overdub, [ ] Software Playthrough ?

Comment 18 Robert Moskowitz 2018-06-03 22:38:27 UTC
I have Fedora 28 with current Audacity, 2.2.2, Lenovo X120e.


I am recording from a USB device connected to an amp. Works fine, except.  If I enable Preferences > Recording > Software playthrough of input, then start a recording, Audacty quits.  I have not seen any errors posted to /var/log/messages.  If there is somewhere else to check, this should not be too hard to replicate.

Comment 19 Robert Moskowitz 2018-06-03 22:50:13 UTC
(In reply to Robert Moskowitz from comment #18)
> I have Fedora 28 with current Audacity, 2.2.2, Lenovo X120e.
> 
> 
> I am recording from a USB device connected to an amp. Works fine, except. 
> If I enable Preferences > Recording > Software playthrough of input, then
> start a recording, Audacty quits.  I have not seen any errors posted to
> /var/log/messages.  If there is somewhere else to check, this should not be
> too hard to replicate.

Looking more at this bug, my problem is different.  So I am willing to open a separate bug report.

Comment 20 Gergely Gombos 2018-07-10 15:44:13 UTC
Same bug here! Turning off overdub in the recording settings solves the issue as a quick fix.

Command line output:
ALSA lib pcm.c:8424:(snd_pcm_recover) underrun occurred
Expression 'err' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3355
Expression 'ContinuePoll( self, StreamDirection_In, &pollTimeout, &pollCapture )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3881
Expression 'PaAlsaStream_WaitForFrames( stream, &framesAvail, &xrun )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4253
audacity: src/hostapi/alsa/pa_linux_alsa.c:3387: OnExit: Assertion `data' failed.
fish: 'audacity' terminated by signal SIGABRT (Abort)

Maybe some ALSA/PulseAudio issue, but I'm not competent in these.

Comment 21 David Timms 2018-10-03 12:17:23 UTC
While there has been no specific fix for this issue, Audacity 2.3.0 has been released and package built.

Can you please check your issue with this version and re-open if it still occurs, listing the package version and fedora release which showed the problem.

Comment 22 Fedora Update System 2018-10-03 13:02:37 UTC
audacity-2.3.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5c01437fa7

Comment 23 Fedora Update System 2018-10-03 13:03:19 UTC
audacity-2.3.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e098024ad

Comment 24 Fedora Update System 2018-10-03 13:04:01 UTC
audacity-2.3.0-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e66ef16e01

Comment 25 Clemens Eisserer 2018-10-03 13:26:04 UTC
it is still crashing: https://bugzilla.redhat.com/show_bug.cgi?id=1635682

Comment 26 Fedora Update System 2018-10-03 15:42:37 UTC
audacity-2.3.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5c01437fa7

Comment 27 Fedora Update System 2018-10-04 18:00:57 UTC
audacity-2.3.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e098024ad

Comment 28 Fedora Update System 2018-10-04 21:10:34 UTC
audacity-2.3.0-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e66ef16e01

Comment 29 Fedora Update System 2018-10-30 17:18:46 UTC
audacity-2.3.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 30 Clemens Eisserer 2018-10-30 20:12:02 UTC
> audacity-2.3.0-1.fc29 has been pushed to the Fedora 29 stable repository. 
> If problems still persist, 

Sure the problem persists, bugs don't magically fix themself.

Comment 31 Clemens Eisserer 2018-10-30 20:14:22 UTC
*** Bug 1644435 has been marked as a duplicate of this bug. ***

Comment 32 Fedora Update System 2018-11-01 17:09:46 UTC
audacity-2.3.0-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2018-11-02 19:21:36 UTC
audacity-2.3.0-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 34 Clemens Eisserer 2018-11-02 19:51:39 UTC
awesome, 2.3 fixed the issue :)


Note You need to log in before you can comment on or make changes to this bug.