Bug 154191 - xfs speedo unreadable
Summary: xfs speedo unreadable
Status: CLOSED DUPLICATE of bug 142744
Alias: None
Product: Fedora
Classification: Fedora
Component: fonts-xorg (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-08 04:58 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 15:56:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/fs/config (919 bytes, text/plain)
2005-04-08 23:20 UTC, Ricky Ng-Adam
no flags Details
/usr/X11R6/lib/X11/fonts/Speedo/fonts.dir (1.65 KB, text/plain)
2005-04-08 23:22 UTC, Ricky Ng-Adam
no flags Details
/var/log/messages (54.58 KB, text/plain)
2005-04-08 23:23 UTC, Ricky Ng-Adam
no flags Details
rpm -qa | grep "xorg" (302 bytes, text/plain)
2005-04-08 23:23 UTC, Ricky Ng-Adam
no flags Details
ls -al /usr/X11R6/lib/X11/fonts/Speedo > speedo.txt (669 bytes, text/plain)
2005-04-08 23:24 UTC, Ricky Ng-Adam
no flags Details
/etc/X11/xorg.conf (2.66 KB, text/plain)
2005-04-08 23:25 UTC, Ricky Ng-Adam
no flags Details

Description Ricky Ng-Adam 2005-04-08 04:58:16 UTC
Description of problem:

with /etc/init.d/xfs restart I get:

Apr  8 00:55:29 localhost xfs[3303]: terminating
Apr  8 00:55:30 localhost xfs[3787]: ignoring font path element
/usr/X11R6/lib/X11/fonts/Speedo (unreadable)

Version-Release number of selected component (if applicable):

fonts-xorg-base-6.8.1.1-1
xorg-x11-xfs-6.8.2-19

How reproducible:

always

Steps to Reproduce:
1.restart xfs
2.
3.
  
Actual results:

warning in logs about fonts

Expected results:

no warnings

Additional info:

Comment 1 Mike A. Harris 2005-04-08 17:57:43 UTC
Please attach the following:
ls -al /usr/X11R6/lib/X11/fonts/Speedo > speedo.txt
rpm -qa | grep "xorg"

Also attach your /etc/X11/fs/config, /etc/X11/xorg.conf, X server log,
and /var/log/messages.  If there is a "fonts.dir" file in the Speedo
font directory, attach it as well.  Please attach each file as an
individual uncompressed file attachment, using the bugzilla file
attachment link below.



Comment 2 Mike A. Harris 2005-04-08 18:02:54 UTC
Setting status to "NEEDINFO", awaiting file attachments requested above.

Thanks in advance.

Comment 3 Ricky Ng-Adam 2005-04-08 23:20:59 UTC
Created attachment 112887 [details]
/etc/X11/fs/config

Comment 4 Ricky Ng-Adam 2005-04-08 23:22:04 UTC
Created attachment 112888 [details]
/usr/X11R6/lib/X11/fonts/Speedo/fonts.dir

Comment 5 Ricky Ng-Adam 2005-04-08 23:23:18 UTC
Created attachment 112889 [details]
/var/log/messages

Comment 6 Ricky Ng-Adam 2005-04-08 23:23:56 UTC
Created attachment 112890 [details]
rpm -qa | grep "xorg"

Comment 7 Ricky Ng-Adam 2005-04-08 23:24:38 UTC
Created attachment 112891 [details]
ls -al /usr/X11R6/lib/X11/fonts/Speedo > speedo.txt

Comment 8 Ricky Ng-Adam 2005-04-08 23:25:04 UTC
Created attachment 112892 [details]
/etc/X11/xorg.conf

Comment 9 Mike A. Harris 2005-04-16 15:55:29 UTC
I've investigated the issue and discovered that starting with the
X.Org X11 6.8.0 release, Xorg no longer supports the Speedo font
type.  It was disabled by Xorg as these fonts have not been produced
in over 10 years, however they neglected to also disable installation
of the fonts, so they still get installed.

We'll be updating our font packaging to remove the fonts and fix the
xfs config to remove the directory from the fontpath.

Thanks for the report and files.

Comment 10 Mike A. Harris 2005-04-16 15:56:21 UTC

*** This bug has been marked as a duplicate of 142744 ***


Note You need to log in before you can comment on or make changes to this bug.