Bug 1542054 - tests/bugs/cli/bug-1169302.t fails spuriously
Summary: tests/bugs/cli/bug-1169302.t fails spuriously
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1544787
TreeView+ depends on / blocked
 
Reported: 2018-02-05 13:22 UTC by Atin Mukherjee
Modified: 2018-03-05 07:14 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.12.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1544787 (view as bug list)
Environment:
Last Closed: 2018-03-05 07:14:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2018-02-05 13:22:24 UTC
Description of problem:

tests/bugs/cli/bug-1169302.t fails spuriously

Fix https://review.gluster.org/#/c/18893/ to be backported into release-3.12.


Version-Release number of selected component (if applicable):
3.12

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-02-05 13:30:32 UTC
REVIEW: https://review.gluster.org/19501 (tests: Fix a broken test case) posted (#1) for review on release-3.12 by Atin Mukherjee

Comment 2 Worker Ant 2018-02-05 14:29:30 UTC
COMMIT: https://review.gluster.org/19501 committed in release-3.12 by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- tests: Fix a broken test case

Issue: When using statedump command to take statedump of the
gfapi process, we specify the following things:

$gluster volume statedump <volname> client <host>:<pid>
   pid: Pid of the gfapi application
   host: This should be the IP/hostname as seen by the glusterd,
         the gfapi application is connected to.

In this test case, if gfapi application is running locally,
and is connected to $H1 glusterd, the <host> need not be $H1.
<host> could be localhost, 127.0.0.1, 127.1.1.1 etc. based on
the configuration of the system. Hence use netstat to find the
right <host> value.

>mainline patch : https://review.gluster.org/#/c/18893/

Change-Id: I6efb9d1ccaf9c6841a9ab7c9ebfecafc03c0bc5e
BUG: 1542054
Signed-off-by: Poornima G <pgurusid@redhat.com>

Comment 3 Jiffin 2018-03-05 07:14:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.6, please open a new bug report.

glusterfs-3.12.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2018-February/033552.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.